PDA

View Full Version : Register OCX Problem (Graphics Server Component)



aellio
11-09-2006, 09:04 PM
This is my first try using Installshield...

I'm setting up an install for a VB6 program that uses a component called Graphics Server. It uses a file called GRAPHS32.OCX.

I put this file in the "Destination computer file's" list with Link to set to <SystemFolder>.

When the program is intstalled on the target machine, the file is there but I try to run the application, I get an error message that the Graphics Server people tell me is because the install program didn't register the OCX.

So I must be missing something in the way I set up Installshield. Any pointers would be appreciated...

Alan

bawilki
11-13-2006, 08:01 PM
You are not alone in this dilema. I also have not been able to register 3rd party ocx and dll files during installation. It is very frustrating and the installshield Docs do not clearly deal with this issue. Could the solution be a custom action?

KathyMorey
11-14-2006, 09:40 AM
First, does the 3rd-party vendor supply a merge module (.msm) or other deployment mechanism for this file? If not, are you sure that you want to put it in the System Folder instead of in your application directory?

To solve the registration problem, go to the component that contains this .ocx file (as the key file) and mark it as "COM extract at build". That will add the registration entries to your .msi file when it is built.

Hope this helps

bryanwolf
11-14-2006, 11:37 AM
For express projects, right-click on the file and choose properties. In the resulting window, you should have a tab that says COm and .NET information. Select that Tab and select the check-box for self-registration. This will self-register the DLL on the system during install time.

You may also de-select the self-registration and try the COM Extract at build option. This is preferable to the self-registration, but may not always work.

More information may be found here:
http://support.installshield.com/kb/view.asp?articleid=Q105291

(Slightly dated, but still accurate)

Wakerunner
08-10-2007, 11:56 PM
And I have the same problem no matter which registration type I choose, Com extract at build and self registration. If I have the UAC on in Vista it works (well sorta, I still get a reg error, but only the first time I run after install, the 2nd run it works without doing anything else...weird). Without UAC on I actually have to manually reg the files with regsvr32.

Is this a problem with Vista or Installshield? Does anybody have a solution that works?

Wakerunner
08-11-2007, 12:01 AM
I also have tried other things I have found in post such as set "Required execution level" to Administrator.

If anybody's answer to this problem is to simply manually register the files, thats not an answer, the whole point of an install program is to install my program so it works. The end user shouldn't have to do anything else. Maybe its time to start loking at alternative install engines.

bryanwolf
08-13-2007, 08:31 AM
What errors are you getting? Why does it work with regsvr32 and not with the installer?

Have you tried both COM Extraction and Self-Registration?

Without details it's hard to say.