PDA

View Full Version : 1155: File C:\...\instmsi30.exe not found



AR Atlas
11-07-2006, 11:41 PM
I just upgraded to InstallShield Express 12. I'm using the standalone editor. I want to make an installer that will install .NET 2.0. But when I tried my installer on a W2K SP4 machine, an error said that to install .NET 2.0, Windows Installer 3.0 would be needed (if this was the case, why didn't Installshield tell me beforehand?)

So I rebuilt my installer, this time telling it to include version 3.1 of the MSI Engine. But now when I run the installer on the W2K SP4 machine I get this error:

"1155: File C:\...\instmsi30.exe not found"

I rebuilt the installer with version 3.0 of the MSI Engine, but the identical message pops up when I try to use the installer.

Could someone please tell me how to fix this?

Thanks!

bkeppler
11-08-2006, 09:35 AM
Did you set the [MSI Engine Location] on the "Build Your Release" screen to "Extract Engine From Setup.exe"? That is the way I have it set up and it seems to work OK.

AR Atlas
11-08-2006, 03:50 PM
Yes, it is set to "Extract Engine From Setup.exe".

You mentioned that it seems to work OK for you. Have you specifically tried it on a W2K machine?

It also seems a little strange to me that regardless of whether I've selected Windows Installer 3.0 or 3.1, the error message always refers to instmsi30.exe

AR Atlas
11-08-2006, 06:07 PM
I seem to have found the problem: There's a field called "Include MSI Engine(s)" that was set to "None".

There's a choice between 9x engine and NT engine, or including both. If I only wish to support Windows 2000 and above (W2K, XP, Vista, etc), is it safe to only include the NT engine?

Thank you for the help!

bkeppler
11-09-2006, 09:39 AM
Glad to hear you discovered the problem. The way they have the "build" screen set up is not the most intuitive! As for the 95 vs. NT engine, I have mine set to NT engine only and it works on Win2K and XP (the only platforms I've tried it on).