PDA

View Full Version : flexnet with linux client errno 141



dmore73
11-02-2006, 10:26 AM
Hi,

I run flexnet with ptc proe licence file on a windows server. I can connect to this server from my windows client who run proengineer.
Then, i want to run proengineer under linux, but i can't connect to the flexnet licence server. i've got a 141 error.

(lmgrd) Write error to client: Connection lost. @ fd:1828 errno:2 (-141)

it's ubuntu 6.10, with portmap and everything good. i need help.

thanks ;)

drrushi
11-28-2006, 03:31 PM
If the server is sending data to a client machine where the process has already terminated or the client's socket already closed, the result is a broken pipe. The Flex error is (-141) and the system error is 32. This error is typically seen on the server's debug log. The scenario in which occurs is when the client has made a checkout request and the lmgrd process on the server is too busy to process at the time. When the lmgrd comes around to process this request the client has already timed out and closed the socket on the client machine resulting in a broken pipe.

hot_magma
04-23-2007, 11:11 AM
Guyzzzzzzzz,

I'm having the same problem :mad: , ddrushi , how can this be solved ??

thanks for the help !!

hot_magma

dsumida
04-26-2007, 11:55 AM
What FNP version are you seeing the error?

Bug IOA-000027799 has corrected the “Write error to client: Connection lost” message This was an erroneous message that we shouldn’t be writing to the debug log. This has been corrected in FNP v10.8.5.