PDA

View Full Version : Can't Install .NET 2.0 Windows Services



brant_burnett
09-19-2006, 11:13 AM
I've been trying for two days to get InstallShield Express 11.5 to install a .NET 2.0 windows service successfully. Based on all the reading I have done, I've tried several different approaches.

1. Checking the Installer Class checkbox on the file. This was working fine for us using Express 11 and .NET 1.1, but I get error 1001 now.

2. Doing #1, but compiling directly in Visual Studio 2005 instead of the standalone program. I get a different error message about being unable to load installer classes, but still error code 1001.

3. Tried adding custom actions to run InstallUtil.exe. However, in doing so it added entries to the binary table to try to stream the file into the setup. After changing it to use the file on the target machine, there is a bug that leaves the entry in the binary file. Based on documentation on the web, I should be able to remove the entries manually using the direct editor. However, Express doesn't have a direct editor, so now my setup project is corrupted and won't compile.

To add insult to injury, apparently all of these bugs have been fixed in the Premier and Professional versions, but no bug patches have ever been issued for Express. On top of that, version 12 (which I assume fixes these bugs) was released two weeks after I bought version 11.5, and they won't give me a free upgrade.

Does anybody know any way to work around these problems? Your help would be greatly appreciated.