PDA

View Full Version : Microsoft SyncToy fails to install?



KrakaJap
08-28-2006, 08:33 AM
Downloaded the Microsoft SyncToy 1.2 straight from Microsoft. There really wasn't any modifications I needed to make... just simply place it in our app server and distribute over AD. However, it fails to install and I can't figure out why. Permission settings shouldn't be an issue on the client machines as this is only being installed on staff/faculty pcs. Has anyone had any problems with this? Any ideas?

EDIT: For anyone else who happens to run into this issue... I managed to solve it by simply manually disabling user dialogs. Not sure why this would effect the installation but maybe one of the dialogs was set to be required somehow. Still fairly new to AdminStudio. :) Hope this will help someone out.

EDIT: Ok so maybe I was wrong... the installation works fine, and the "first" run works fine but when I go to run SyncToy a second time I get an error. If I choose to ignore the error and continue, SyncToy starts but is all screwed up... icons are misplaced, elements that obviously should not be visible are visible, etc. If I reboot the machine I can run it again (once) and everything is fine but if I shut down the app and load it again I continue to get the same error.

error: Requested registry access is not allowed.
System.Security.SecurityException: Requested registry access is not allowed.
at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
at System.Diagnostics.EventLog.FindSourceRegistration(String source, String machineName, Boolean readOnly)
...

So I ran regmon with a "DENIED" filter and added custom permissions to all registry locations that were denied. But of course this did not help.

If someone could please take the time to help me out on this one I would greatly appreciate it. This is such a small, simple utility that apparently does not want to be distributed as managed software on a locked down network.

KrakaJap
09-11-2006, 02:56 PM
Also note that the entire campus is locked down so giving Full permissions to everyone is not an option. :(