PDA

View Full Version : Error 5037



Meshman
08-15-2006, 12:05 PM
Next error:

5037: Internal build error

This error occurs during build time in the following scenarios:

1 - Invalid entries exist in the Directory table.

I have to download and install the entire MS Installer SDK?

2 - MDAC 2.5 Proxy Merge Module is included in the project.

Not the problem.

I don't understand half the terminology they're using let alone identify what the problem is. I'm just trying to create a distribution package.

Meshman
08-16-2006, 10:08 AM
I solved this and all my distribution problems by removing the product and abandoning it for one that actually works. I don't have time for this nonsense.

martin.serrano
08-21-2006, 06:42 PM
I have to say, InstallShield seems incredibly difficult to use. But maybe I'm just missing something.

Christopher Painter
08-21-2006, 07:18 PM
There seems to be this myth out there that Setup Engineering is `easy`. You know... xcopy and double click shortcut to the EXE. When people stumble onto harder things they blame the tools. The truth is we do the hardwork so that the user, not the developer, has a wizard like experience.

Seriously.... Meshman has been a member for over 2 years and still hasn't figured out how to use InstallShield? I seriously doubt that his problems will magically go away because he's going to go use a different tool.

martin.serrano
08-22-2006, 06:57 AM
I understand Setup Engineering is not easy. But I do think that the out of the box experience of Installshield Express 11.5 is not great. I quickly ran into things that did not work and it is that is where my greatest frustration lies.

Not that "things" should just work, but that when they do not, that there is good documentation and support (both in the software and by the supplier) to solve my problems. Then I find out that my ~$450 for Installshield doesn't buy me any support and that when I run into an issue like those below I'm stuck trying to navigate a morass of cryptic log messages depending solely on the kindness of strangers to help me figure it out.

1) My dotnet client doesn't launch after install although the installed version works. (I ended up launching it myself with a custom action).

2) Download of dotnetfx works but install silently fails. (I still haven't figured this one out)

So the manual is okay helping as long as things work as expected, after that it becomes a large time sink. My expectation was that this tool would save me more time.

RogerC
02-25-2008, 10:49 AM
I've been having this same problem with InstallShield 2008 Premier. I scoured the Component and Directory tables for illegal entries, and found none. Then I found a solution that somebody posted on Experts Exchange, and it worked for me. I turned off .NET dependency scanning for all the components in the project, and the error 5037 went away. I then explicitly added the CR XI merge module back into the project, and it still builds without error.

Meshman
02-25-2008, 10:57 AM
"I turned off .NET dependency scanning for all the components in the project"

I tried that. As soon as I do that, ALL 3rd party .Net components are dropped from the project (because it didn't scan for them). Sure it builds without error but just crashes when it runs because half the application is missing. Turn it back on and it streams errors.

I never solved this. The help from Macromedia has been 0. The same 1/10 rating I give the product coincidentally.

Thanks for the note though.