PDA

View Full Version : XML File changes - two problems



BerndT
07-06-2006, 03:37 AM
I'm now testing an evaluation copy of Installshield 12 because I want to check how this XML File feature work in this version.

I want to install a .Net application with a XML file. The setup shall install a XML file and then write different entries into this XML file depending on the installed features.
The application read the XML into a dataset.

The oiginal XML file looks like this:
<?xml version="1.0" standalone="yes" ?>
<SystemData xmlns="http://ebv.com/20040119/SystemData.xsd">
<SystemSettings>
<value1>vv1</value1>
....
</SystemSettings>
</SystemData>

The setup shall insert entries like this:
<feature1 key="a">
<attr1>aaa</attr1>
<attr2>bbb</attr2>
</feature1>

The output look like this:
<?xml version="1.0" encoding="UTF-16"?>
<SystemData xmlns="http://ebv.com/20040119/SystemData.xsd">
<SystemSettings>
<value1>vv1</value1>
....
</SystemSettings>
<feature1 key="a" xmlns="">
<attr1>aaa</attr1>
<attr2>bbb</attr2>
</feature1>
</SystemData>


Problem 1: the setup changes the first line from standalone="yes" to encoding="UTF-16".
Problem 2: the setup inserts xmlns="" into the feature-nodes which make our application crash.

Does anyone know a solution for those problems?
The features gives the decission to buy or not to buy this product.

Best regards
Bernd Tabel

MichaelU
07-10-2006, 10:52 AM
These are both known issues with the product; the work order numbers you can use to track these issues are IOC-000044312 and IOC-000050719 respectively. I can't offer any estimate as to when fixes for these issues will be released; if you need fixes these behaviors immediately, I would suggest you implement custom support.