PDA

View Full Version : Install from the WEB for v12 == Nothing happens



lansdale
07-02-2006, 07:36 AM
Hi

I've upgraded all the way from ISv3 through to (now) ISv12. I used "Install from the WEB" for some time until end-user install problems caused me to dump it (Developer 8). I decided to give it a try again with IS12.

I have problems. The .msi file is downloaded along with its support files to the TEMP directory. Once it starts to execute nothing happens. I've gone thought a lot of ISFTW debugging before. I checked the MSI log files and the most it mentions is "12029" which is a MSI HTTP connection problem. I tried it on various machines and site locations, so I doubt it is due to a proxy problem. I've using v2 MSI installer, and have asked that is be embedded in the setup program (my typical default setting).

Just after I got IS12 last week I compiled the WEB version and it did get past this point, where it actually started to download files. But, it reported "Transfer error -2", an error I'm still awaiting an answer from a couple of years ago in the Developer 8 forum.

I've resorted to posting in the forum since I've tried almost everything and nothing is letting me progress on these problems.

Any suggestions where to look next, where to get some more debugging info, or what could be causing these problems?

Thanks.

lansdale
08-19-2006, 01:18 AM
I still haven't heard back from anyone at Macrovision about this damning problem so I decided to try some more debugging myself.

With my current installation the problem not much better. Here is what I see now:

- I execute setup.exe on the web site.
- Setup.exe downloads, executes, downloads my .msi file
- Setup.exe shows "Extracing issetup.dll". 75% the way through the status bar setup.exe exits and that's the end of it.

I enabled MSI error logging, but of course it never gets to run the .msi file. I watched the \temp directory while the files were being downloaded + executed, but found no clues there.

What can I do to determine why setup.exe is exiting early?

lansdale
08-20-2006, 06:42 PM
For the ISv12 development team, I decided to create a simple "Installscript MSI" project, WEB enabled. I used all default options and it installs a single file.

The installer can be run from:

http://www.okino.com/download/demos/test/setup.exe

Again, it simply exits after extracing the .dll file, as mentioned before.

I've made sure that the case of the filenames are proper, as I know that has always been important for proper WEB execution.

I can upload the project file if needed.

Ramose
08-29-2006, 11:48 PM
I got a reply from the support incident I opened

This problem has been reproduced and determined to be an issue in our software. The nature of this issue is that ISSetup.dll is being placed side-by-side with setup.exe when building a web release, rather than streamed in setup.exe which will result in a functional InstallScript MSI Downloader project. This issue has been submitted to our Engineering team as issue #IOC-000053087. At this moment, there is no estimated time frame for when this issue will be fixed. For an immediate resolution, I recommend switching to a Single-EXE release type, as it is not possible to stream ISSetup.dll into the built setup.exe. You can track the status of this issue using the issue number by checking product release notes or searching our Knowledge Base through eService.

lansdale
08-30-2006, 02:35 AM
Thank you for migrating this issue into a tracked bug. At least I now know I was not dreaming of this being a problem of my own making.