PDA

View Full Version : .NET 2.0 won't Install



cari@msi
06-29-2006, 11:35 AM
:confused: Ok this is probably a really stupid question but for some reason I can't get the .NET 2.0 framework to install with my .NET application. I am working with a Basic MSI project. I have selected it in the release window, (and Windows Installer 3.1 selected) tried the Copy from Source Media option as well as the Extract from Setup.exe and neither installs the framework when I run the Setup.exe file. When I use the Copy from Source Media option, the dotnetfx.exe and dotnetfx20.exe files are found in the Disk 1 folder and if I run the dotnetfx20.exe file, it will succesfully install the framework, but I really would like it to installl when the application setup.exe is run. I was able to do this with the 1.0 framework in Installshield X using the Copy from Source media, but we have since upgraded our applications to use .NET 2.0. If anyone can please help me I would really appreciate it! Thanks

Cari

MichaelU
06-30-2006, 10:12 AM
Are you getting any error messages, or does it just not try to install the framework? Is the framework already installed on the machine you are testing? If you do an uncompressed build, what value do you see in Setup.ini, section [Startup], for DotNetVersion=?

cari@msi
06-30-2006, 10:49 AM
There are no errors being passed at all, which makes this all the more difficult... :( The installation computer does not have .NET on it. It is a wiped machine with nothing but Windows XP Service Pack 2. My build computer does have the .NET 2.0 framework installed. Am i supposed to have Visual Studio 2005 installed on this machine as well? The Setup.ini file under the [Setup] section has DotNetVersion=v2.0.50727. I even made an installation that has nothing but a single database in it with the prompt to install .NET 2.0 and not even that can I get to work. I also have the .NET Dialog option set to yes and when I have the option dialog come up and I click yes, the windows Installer frame comes up momentarily and then doesn't finish installing. It's like something else is stopping it from completing the install. I can however, click on the dotnexfx20.exe and the .NET 2.0 framework will install just fine. Thanks for your help, I wish I knew more about Installshield so I could get this working myself!!

Cari

MichaelU
06-30-2006, 12:45 PM
You should also have a file "dotnetfx.exe" in your built DISK1 folder. Is that file about 300Kb (as opposed to around 20Mb)? If not, you could try replacing that file by running the InstallShield 12 repair option in add/remove programs, possibly after renaming <ISProductFolder>\Redist\0409\i386\dotnetfx.exe. If dotnetfx.exe looks fine, assuming this isn't a problem with your one XP test machine, I'm out of good ideas; as far as I know this usually works fine. Perhaps our support staff can help you further on a support request.

Christopher Painter
06-30-2006, 01:16 PM
FYI, if this is a simple wiring problem then this a good place to ask questions. But if you find that the EXE is where it is supposed to be and InstallShield is invoking it with the command line that it is supposed to, and it still doesn't work.... then I would be sure to go check out Aaron Stebner's BLOG ( MS Employee fmr member of .Net team ) and check out his articles and excellent personal help.

cari@msi
06-30-2006, 02:05 PM
Thank you Michael, I did the repair and it did work. I think I may have downloaded over the dotnetfx.exe file that was the smaller size. Thank you again! :D

eRempel
08-31-2007, 11:11 AM
I had the same issue and was able to resolve it by right clicking on the dotnetfx msi file and clicking "properties"

Under the "General" tab at the bottom is an "Unblock" button. The text says, "This file came from another computer and might be blocked to help protect this computer". Clicking "Unblock", applying, and the rerunning the file worked.

I think our domain group policy is causing this

Good luck:)