PDA

View Full Version : This is insane!! Please help



google44
06-26-2006, 04:23 PM
Why i so dificult to change a bitmap ? I'm trying to change the left side bitmap of the standard dialogs on an Installscript msi project. I even delete BitmapId_103 and replaced with my own image. Change path to my image at all dialogs containing BitmapId_103. No effect. The standard bitmap still showing when installshield initialize. I don't know from where it loads because it isn't on my drive. What can i do ? I have a deadline and i'm stuck at changing a bitmap :mad:
Please help cause is driving me crazy :(
Edit: I have never seen something like that in my life. I edited IsDialogBitmap.ibd, after reading a newsletter from InstallShield. No effect at all, bitmap is still there and appears when installshield initialize. I don't know what to do anymore.
Why in the hell do someone hide a simple bitmap so well ? For what ?

RobertDickau
06-27-2006, 10:31 AM
Is it just that one initialization dialog box that isn't changing? If so, the issue is that that dialog is provided by setup.exe and isn't one of the InstallScript dialog boxes. As described in the last paragraph of that newsletter tip (http://www.installshield.com/news/newsletter/0301-articles/DialogBitmaps.asp), you can use the Small Initialization Dialog setting to display a dialog box without that bitmap.

google44
06-28-2006, 05:05 AM
Is it just that one initialization dialog box that isn't changing? If so, the issue is that that dialog is provided by setup.exe and isn't one of the InstallScript dialog boxes. As described in the last paragraph of that newsletter tip (http://www.installshield.com/news/newsletter/0301-articles/DialogBitmaps.asp), you can use the Small Initialization Dialog setting to display a dialog box without that bitmap.

I solved the problem, finaly, but with alot of work.The newsletter it only applies to InstallScript project not InstallScript MSI which i use.
The only solution for that is to change bitmap inside _IsRes.dll located at C:\Program Files\Macrovision\IS12\ObjectsPro\InstallShield Object Installer. Of course, i backup it first.
It took me 5 hours of testing and searching through .dll's to find the right one because there isn't one word about that on the web.
I hope i spare someone the pain of changing that damn bitmap.