PDA

View Full Version : Objects for NT services



neelneelu
06-22-2006, 07:09 PM
Hi

I am upgrading to IS 12. My previous install had objects for NT services. IS 12 does not support objects for NT Services and it is gives errors.

Can anyone please help me to find work around for this.

Thanks in advance

Neel.

DebbieL
06-23-2006, 08:07 AM
What errors are generated?

InstallShield 12 InstallScript projects cannot consume objects that were created with earlier versions of InstallShield. If you are working with an InstallScript project that was created in InstallShield 11.5 or earlier, and you upgrade it to InstallShield 12, any references to objects are updated to point to the InstallShield 12 versions of the objects, if they are present on the system. If a version 12 object isn't present on the system, you'll get an error at build time telling you that the object could not be found. Perhaps that's what's happening in your project? If that's the case, you may need to download the objects (http://www.macrovision.com/downloads/index.shtml).

Debbie Landers
Macrovision Corporation

neelneelu
06-28-2006, 01:17 PM
Hi

Thanks for the reply. I was using Installshield 6.3 before and it has one object which was created as NT service Object inorder to configure service on target system.

I tried to port the earlier scripts on Installshield 12 but I was getting error code 125 (only while building it not while compling). I tried downloading objects but it did not help. I get the same error again. It says" unable to load Installshield Object"

What should I do to get configure the Service to the target system??

Please Help !!!

DebbieL
06-28-2006, 01:43 PM
You dowloaded the InstallShield 11 InstallScript Objects item, right? That's the download that includes the NT Services object for InstallScript projects.

If you've installed the InstallShield 11 InstallScript Objects download, the NT Services object is available in the Objects view of InstallShield 12. (In the View List under Application Data, click Objects.) In the InstallShield Objects/Merge Modules pane of that view, select the NT Services object, and drag it to the feature in the Features pane that should include this object.

To resolve the build error, you may need to find the old version of the object in the Features pane of the Objects view and delete it.

I hope that helps.

Sincerely,
Debbie Landers
Macrovision Corporation

neelneelu
06-28-2006, 03:09 PM
Hi Debbie,
Thanks Again, but I have installed the latest objects and merge modules not the Installshiled 11 objects. If I need to download Installshield 11 objects then how should I do that. I can see only IS 11.5 InstallScript Objects, IS 11.5 MSI Objects and IS 11.5 legacy Istallscript Objects. Which one should I download and where should I install them ?? ( Is it in c:/programfile/macrovision/IS12/Object??)

Is it ok to download IS 11.5 objects instead of IS 11 ??

Thanks.

DebbieL
06-28-2006, 03:21 PM
Sorry for the confusion.

I guess that the easiest way to obtain the object that you need is to check for updates from within InstallShield:
1. Open InstallShield 12.
2. On the Tools menu, click Check for Updates. InstallShield launches the Update Service, which checks to see if any updates are available for the version of InstallShield that you are running. If one or more updates are available, the Update Manager opens.
3. In the list of updates, select the InstallShield 12 InstallScript Objects check box, and then click the Install button. (As an alternative, you can select that check box and then click the Download Only button. Doing so downloads the installation to wherever you specify. Then you can double-click the file to launch the object installation.)

When you run that installation, InstallShield lets you pick which InstallScript objects you want to install. You can install all of them (including the NT Service one) or only the ones that you need. The installation will install them to the appropriate location in the InstallShield Program Files folder.

Debbie Landers
Macrovision Corporation

neelneelu
06-29-2006, 11:45 AM
Thanks. I was able to install NT services.