PDA

View Full Version : Installshield 12 Pro error from command line



alam2k4
06-19-2006, 05:19 PM
We just upgraded from Installshild 11 to 12 Pro. and I need to build from the command line, its just giving up halfway through. no useful information in the log either. from the gui it perfectly. Am I missing something? i am using C:\Program Files\Macrovision\IS12\System>IsCmdBld.exe -p <Project Directory>\project.ism

Please help.

Mike Marino
06-19-2006, 10:16 PM
Can you re-run the command line build, and add the -v parameter (verbose). That might give a clue to what is happening.

If not, please post the log that you do get, that might help us pin down what is going on.

Christopher Painter
06-19-2006, 10:25 PM
Are you using merge modules? Are you setting your merge module path?

alam2k4
06-21-2006, 10:59 AM
Yes we are using merge modules. We are using Finalbuilder to automate the build process. Is there an option where you can set the merge modules paths for the command line run?

Christopher Painter
06-21-2006, 11:05 AM
ISCmdBld does not. ISSaBld has the -o argument for setting the path.

Ideally your not using ISCmdBld on a devloper machine but ISSaBld on a production build machine. ( aka clean build machine ). But if you must use ISCmdBld you can put a task in your build script to tweak the value in the registry under HKCU\Software\InstallShield\12.0\Professional\Project Settings\MMSearchPath

alam2k4
06-21-2006, 11:59 AM
Christopher, Thank you very much for your reply. We have the project with .ism extention. I dont have to use ISCmdBld, If I want to start using ISSaBld, what changes will I need to make?

Christopher Painter
06-21-2006, 02:05 PM
Not many. Just put ISSaBld on your build box instead of the full blown IS 12. Change your build automation to call the new EXE and pass in a -o argument for your merge module path. If your making any calls to the IS Project Automation object you'll have to change the ProgID as the class's have different signatures in COM.

alam2k4
06-21-2006, 02:31 PM
I tried the registry key settings, and did a verbose build from the command line with IsCmdBld, and it does not show that its merging modules instead it goes to scanning .net dependencies and after it finds the last one, it just ends. Any thoughts Christopher?

Christopher Painter
06-21-2006, 02:44 PM
Does your project build through the IDE?

What happens if you remove the last component that it processed? Does it still quit or does it continue?

alam2k4
06-21-2006, 06:10 PM
well i finally found out that it was failing at the dependency check for some .net components. It worked after I changed it to only "properties". Thanks for your help.

Mike Marino
06-21-2006, 09:33 PM
We traced this down on our side and we are pretty sure we know what the problem is. Our .Net Scanning code was having a problem reading one of our XML files. We used MSXML3 do to the reading. Switching our code to use MSXML4 fixed the problem. Attached to this message are two dlls that fix tihs problem. Hopefully these will fix the problem for you. There are two files in the attached zip file:

ISWIScanners.dll is for our Main product.

ISScan.dll is for the standalone build.

Replace the version you have with the version in this zip file and I think the problem will be fixed.

Let me know if this does not work.

Thanks,
Mike

Jody Brooks
12-14-2006, 09:09 AM
I had this exact same problem. The DLLs included did indeed solve the problem for me in both cases (IsCmdBld.exe and IsSaBld.exe).

I wonder though as I just received and installed the software (InstallShield for Windows 12 Pro) and did all the updates (except for the InstallScript objects -- we don't use InstallScript) and still had this problem. That means to me that these DLLs aren't in an update yet even though the last message on this thread was June. Shouldn't these DLLs be in an update by now?

Anyway, thanks for the help. I'm glad I happened up on this thread.