PDA

View Full Version : FeatureIsItemSelected does not work after migrating to IS 12



oivind-i
06-19-2006, 08:58 AM
Have an old "Installscript MSI Project" which has survived several migrations, but not to IS 12 ...

The IS script function call:


nResult = FeatureIsItemSelected (MEDIA, "Instructor_Station");
does'nt seem to work any more, get the error 132 ("The specified media cannot be found. ").

This is straight from the Help examples and I'm sort of lost here ...

MichaelU
06-19-2006, 10:33 AM
Are you using this in an event, or invoked as a Custom Action? If at all possible, I would suggest using it from an event (OnFirstUIBefore, etc.) and storing the value to an MSI property, which the Custom Action can then query.

oivind-i
06-20-2006, 09:30 AM
It's a Custom Action.
I tried to move it to OnFirstUIBefore() and then it works :o

I'm a bit puzzled though, because this worked fine on several previous versions of IS (what I try to say is that this is a bug or ???).

Anyway, this solved my problem - thanks :)

MichaelU
06-20-2006, 10:55 AM
It's due to the engine restructuring, which is itself a good thing. Whether this side effect is a bug or not I'm not familiar enough with that aspect of the design to know. It certainly smells like a bug, and while it could be a legitimate limitation, at the very least it should be covered in the migration KB. I'll raise the issue internally.

andyamstrad
10-27-2006, 05:28 AM
Is there a fix for this, because this is a serious limitation.

Nitesh
08-26-2013, 09:12 AM
I am also getting the same problem.
I used the
nResult = FeatureIsItemSelected(MEDIA, "Employee View", FALSE);

it always gives the result of -132.

Can anyone help on this.