PDA

View Full Version : problem running an exe installed with product



tsdico
06-15-2006, 01:46 PM
this is a simple thing that should be brainless to get working but... I guess I'm becoming brainless!

I've created (via the project assistant) the custom action to launch my program at the end of the install should the user elect to do so. problem is, the app isn't launching!

I've tried several tests with other small, simple applications in place of the main .exe and they run. I even tried inserting a problem into the sample app thinking that perhaps an exception at run time might prevent it from launching - the sample app ran fine (that is, it displayed the exception and died, confirming that the CA did its job)

I've tried manually running the app after install and it runs.

so what gives? its almost like the Filekey is invalid for that file or something - is that possible? is there a way to determine this?

I've removed and re-added the file in question with no change in behavior.

RobertDickau
06-15-2006, 03:23 PM
If you generate an MSI log file at run time, does it tell you anything? Or does validating the built MSI database point to anything? Or does the Custom Actions view show anything odd about that?

Here's a DevLetter tip that describes the general idea: http://www.installshield.com/news/newsletter/0505-articles/launch.asp.

tsdico
06-16-2006, 08:25 AM
I wasn't installing the RTC api merge module, which was causing my app to silently fail without any exceptions.

works great now that I'm including the MSM!