PDA

View Full Version : MDAC setup prerequisite



Jennifer
06-13-2006, 01:19 PM
InstallShield 12 has MDAC 2.8 as a setup prerequisite rather than a merge module. Is this the preferred method for distirbuting MDAC 2.8? But what if I only want MDAC 2.8 installed with a particular feature??

sjimmerson
06-13-2006, 02:17 PM
I have both a Prerequisite and a merge module listed in the Redistributables pane for MDAC 2.8 in InstallShield 12.

Jennifer
06-13-2006, 03:57 PM
ok, I had to download it

Christopher Painter
06-13-2006, 05:26 PM
In most cases stand alone EXE prereqs from Microsoft are better then MSM's but since MDAC isn't an MSI based program in the first place it probably really doesn't matter.

To get the functionality that you want is interesting. I basically write my own bootstrapper that has logic of mandatory vs optional. To keep things simple you could make the prereq say that some feature optional requires MDAC and then put logic into your install UI that won't let the install proceed if a certain feature is being installed and MDAC wasn't installed.

Or just go with the merge module.....