View Full Version : Cannot install .NET Framework 2.0 on NT4 SP6 system

05-22-2006, 03:46 PM
Setup.exe starts and then immediately trys to install .NET 2.0. I get the following error:

1210: Setup requires Windows Installer version 3.0 or higher to install the Microsoft .NET Framework version 2.0. Please install the Windows Installer version 3.0 and try again.

This is very similar to a problem we had with Installshield 11.5 that has been fixed in release 12. When trying to install on a system with Windows XP SP1 (Windows Installer 2.0), the installer would not honor the "Best Fit" option to install Windows installer 3.1 and the the .NET installation to fail.

This release has:

MSI Engine Location: Extract from setup
MSI Engine Version: Version 3.1 or 2.0 (best fit for system)
.NET Framework Location: Extract from setup.exe
.NET Framework Version: .NET 2.0

Christopher Painter
05-22-2006, 04:16 PM
Is this a trick question? :)

NT 4.0 is not a supported OS for .Net Framework 2.0


05-22-2006, 04:17 PM
NT4 is not supported by .NET 2.0 - see http://www.microsoft.com/downloads/details.aspx?FamilyID=7abd8c8f-287e-4c7e-9a4a-a4ecff40fc8e&DisplayLang=en for the list "Windows 2000; Windows 98; Windows 98 Second Edition; Windows ME; Windows Server 2003; Windows XP".

I think this is largely because of a MSI 3.0 requirement on NT based systems; MSI 3.0 supports "Windows 2000 Service Pack 3; Windows 2000 Service Pack 4; Windows Server 2003; Windows XP; Windows XP Service Pack 1" (http://www.microsoft.com/downloads/details.aspx?FamilyID=5fbc5470-b259-4733-a914-a956122e08e8&DisplayLang=en), so at least the Best Fit option is doing the right thing on NT4Sp6.

With this information in mind, does the current behavior make sense, or what behavior would you like to see?

Christopher Painter
05-22-2006, 04:19 PM

Beat you! :)


05-23-2006, 10:55 AM
Thanks guys. You are correct. After researching this I found that neither Windows installer 3.1 nor .NET Framework 2.0 is supported on NT4. I guess we tell users still on NT4 that we cannot support them. Sigh...