PDA

View Full Version : LMGRD starts and runs in a DOS window, but not as a service



sduncanae
05-15-2006, 11:33 AM
On certain Windows XP Professional PCs, LMGRD 10.8.0.1 and/or 10.8.0.6 fails to start as a service at boot time. Using LMTOOLS, you configure and save a service normally. If you do not check the “Use Services” box, you can go to the Start/Stop/Reread tab and start and stop the server reliably. Once you check the Use Services box and save the service, however, LMGRD fails to start.

At boot time, there are two errors in the PCs event log:

1. “Timeout (30000 milliseconds) waiting for the flexlm service to connect.”
2. “The flexlm service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.”

Attempting to start the service from the services manager (services.msc), the error is:

“Could not start the FLEXLM service on Local Computer Error 1053: The service did not respond to the start or control request in a timely fashion.”

Indeed, it does not start. If I change the "Log on as" attribute in the properties for the service to be either "me" or "administrator" instead of system, it says it fails, but lmgrd really does start at boot time.

Clues:

There is nothing wrong with the license file, host id or daemons. LMGRD runs fine in a DOS shell. At one time, LMGRD used to start as a service on this PC. I have checked the permissions on the daemons, which didn't really change and they are accessible by all three accounts. It does not seem like a timing or dependency problem, since it cannot be started manually either. The normal entry defining the service gets properly created in the registry under:

HKEY_LOCAL_MACHINE\SOFTWARE\FLEXlm License Manager

I can start the daemon every time using the following DOS shell script example: “start_lmgrd.bat”

Looks for running lmgrd, kills it and restarts lmgrd and vendor daemon is separate DOS shells. Note “taskkill” is a standard part of windows XP.

echo off
taskkill /F /T /IM lmgrd.exe
echo Wait 5 seconds then press any key...
pause >null
cd c:\flexlm
lmgrd -c license.dat

sduncanae
05-22-2006, 11:37 AM
I still don't know the root cause to this problem, but another workaround aside from starting lmgrd in a DOS shell is to manually create a service outside of lmtools. The downside is that you will not be able to start or stop it with lmtools.exe either. At a DOS prompt, type:

sc create "FLEXLM" binPath= "C:\flexlm\lmgrd.exe -c C:\flexlm\license.txt
-l C:\flexlm\flex.log"

All on one line, with the paths customized for your installation. Note the no-space before the equal sign and the space after. You still get an error in the event log, but it does start (at least for me).

Windows XP has the sc (service create) command built-in, but for Windows 2000 you will need to download sc from the resource kit:

ftp://ftp.microsoft.com/reskit/win2000/sc.zip

Steve

konus1
03-22-2007, 08:30 AM
I can confirm the above problem description.
All of a sudden, the installed LicenceManager (we use it for Autodesk-Products) did not work as a Windows-service anymore.

Install of the new Versions of lmgrd and lmtools did not help.

At the moment I start it manually after reboot - very dissatisfying.

gdellunto
06-08-2007, 09:43 AM
This issue has been haunting me for weeks aswell.

I applied a patch I received from Rational support at IBM, it upgraded the core licensing files and therin was the resolution. Something must have been updated in the lmgrd.exe file that now allows the file to run as a service on W2003 server. One thing I noticed is that two lmgrd processes now run, not sure why but I installed the update on a couple of PCs and the same behaviors existed.

Hopefully what resolved my issue, will resolve yours as well.

Post this elsewhere, I noticed a lot of people with the same issue.

What a releif!!!


Where to get patch:
Direct to patch:
ftp://ftp.software.ibm.com/software/rational/web/lkc/RatlLicServer7.0update.zip

or

http://www-1.ibm.com/support/docview.wss?us=727&uid=swg21250404



Link to download is half way down page... see bold/underlined text below.

Windows License Server Update
The steps below outline the process for obtaining and installing a patch to the v7.0 Rational License Server for Windows that will support keys for RSA, RSM, RSD, RAD, RFT, RMT and RPT.

***You do NOT need to upgrade your license server if you are not using keys for the above products.

If you are already using v7.0 of the Rational License Server for Windows (this version of the server became available in June of 2006 and has been included with shipments and downloads of ClearCase, ClearQuest, Team Unifying Platform, Rose and other classic Rational products) you can download a license server patch (4MB .zip) that you can apply on top of the 7.0 version of the license server for Windows. There is a README in the zip file that provides installation instructions.

stefanta650
10-21-2009, 03:09 AM
Hi there!
We are running lmtools on a server. In the case that a client appliacation hangs it may happen that the license will not freed. So the workaround is to stop the license server and restart it. This works fine using the provided GUI. But the administrator as to remote-login to the server and do this manually. My idea is to provide a small batch which can be started from the client machines to shutdown and restart the license-server.
So far I managed to shut down the server using the command "l:\flexlm\lmutil lmdown -c <licensefile>" where l: is the linked directory from the server. I tried to start the server using "l:\flexlm\lmgrd -z -c <licensefile>". But that doesn't work. I got the following error message (where pc_007 is the client-machine from where the lmgrd-command has been startet)

(lmgrd) pid 3120
(lmgrd) "<client_name>": Not a valid server hostname, exiting
(lmgrd) Valid server hosts are: "<server_name>"
(lmgrd) Using license file <license_file> (which is the correct one...)

Can anyone help me with this problem??

Thanks in advance and kind regards!
Stefan

RobertDickau
10-23-2009, 03:27 PM
Is it an option to use the GUI lmadmin interface? The license administration guide has more information.

If not, it's probably the same situation as a client running a copy of Notepad that's on the server, where the client is the system actually executing the code. It might be necessary to find a utility that will run remote processes; some years ago, Sysinternals had a "psexec" utility that served this purpose, and your version of the OS might have something built in.