PDA

View Full Version : InstallScript Custom Action crashes on Win98 SE



rrother
05-10-2006, 06:26 PM
Attached is a 1 file install. It works fine on a XP machine but not on Win98 SE. If I remove the custom action, it works OK on Win98 as well.

Christopher Painter
05-11-2006, 07:41 AM
I looked at the rul file ( basically a no-op ) and the logfile and don't see where it fails.

MartinMarkevics
05-11-2006, 09:20 AM
Could you please try it with the latest version of the engine (ISSetup.dll)? Just unzip the attached file and replace the copy of ISSetup.dll that's in <IS 12.0 Install Location>\Redist\Language Independent\i386 (typically this path is something like C:\Program Files\Macrovision\IS12\Redist\Language Independent\i386).

Once you have done this, rebuild your setup and run it on the 98 machine.

MartinMarkevics
05-11-2006, 09:22 AM
Looks like the attachment did not get added to my last post for some reason. Trying again...

rrother
05-11-2006, 10:28 AM
Latest version of the engine fixed the problem.

Thanks. Version 12 looks good and also fixes a few issues I saw with 11.5.

Ron Rother

MartinMarkevics
05-11-2006, 11:33 AM
Great. I'm glad it works now. Thanks for testing out the new version of the DLL.

I'm pretty sure I know what the issue was. Unfortunately, this particular fix did not make it into the Beta 2 build, but if anyone else is running on 9X and seeing any issues, download ISSetup.dll from this thread and it should fix the issue.

Christopher Painter
05-11-2006, 01:42 PM
I sure am glad you guys are fixing these problems real quick cause I sure did put myself out on a long limb with my tribute to the IS refactor changes. :)