View Full Version : Strange Behaviour

05-10-2006, 03:57 AM
Hey Guy's,

I'm using the IS12 Beta1 right now and i'm having a rather strage problem with my installer.
I had an installer that worked pretty fine before i began to modify it. The midifications were simple but the consequences were huge. So what did i modify?!
1. I put an icon in one of my custom dialogs
2. i calculated and put the Disk space on SdStarCopy dialog using GetDiskSpaceEx

It worked all pretty good but.....

the consequences:
1. None of my permissions were set properly(for example i gave READ and Generic All permissions on a folder to IWAM_Username). Instead of just Read or just Write permissions the IWAM/IUSR users had full control permissions.
2. The shortcuts were not functioning any more.

I myself don't think that what i did could in anyway cause so much damage to the Setup, even after debuging and validating the package i found no new generated failure that could possibly have caused this....

could anybody say how such a thing can happen....

05-10-2006, 06:40 AM
after hours of searching and testing i solved the problem...

First of all
Generic all = Full Control(i didn't know this), the reason i gave the users this permission was the fact that the previous permissions did nto work well, they were there but they were not effective.
How did i managed to make my permissions effective then?! After giving a user write and/or execute permissions i made sure that in the advanced tab the "Generic write" and/or "generic execute" were checked also.

well that did the job for me and surprisingly my Shortcuts are working too....