PDA

View Full Version : BetaRefresh License Error



Christopher Painter
04-15-2006, 08:04 AM
I'm getting a 310 Error when I install IS12 Beta2 on a laptop at home. Here is the scenario:


I had IS12Beta1 installed earlier. The harddrive started to fail so I purchased a new harddrive. I used Acronis True Image to save off an image of the hard drive to another computer and restored the image file to the laptop.

But when I used windows I was having problems with virtual memory. Windows Home Edition just couldn't get the swap file to work. So I wiped all the partitions and did a clean install of Windows XP Professional SP2.

This morning I installed IS12Beta2 and I get the error message.

Editorial: I've heard alot of IS people complain about the DRM in InstallShield since it was purchased by Macrovision. I'm afraid it might drive away customers.

lysemose
04-18-2006, 02:51 AM
After installing IS12 Beta2 on a fresh WinXP machine I get the error message "Unable to install an evaluation license (error 310) when I launch IS12. This is a show stopper preventing me from testing.

Mike Marino
04-18-2006, 09:28 AM
Did you machine with the "Fresh" Xp have our beta on it before you re-installed Windows?

We are working on a solution for this and should have a fix posted for users having trouble sometime later today.

Christopher Painter
04-18-2006, 09:38 AM
This simple answer is yes and no. :) The machines previous harddrive was Windows XP Home and it had IS 12Beta1 installed. An attempt was made to save the Primary Active partition to an image file using Acronis TrueImage and restore it to the new harddrive. However Windows was too corrupt from dataloss of the original harddrive failure so the partition had to be destroyed and Windows XP Pro reloaded from scratch.

Obviously enough of IS12Beta1 survived on the new hard drive to confuse the installation of IS12Beta2. Without going into details I know some of the implementation details behind the scenes as a result of troubleshooting this during the last BETA.

SherylSikora
04-18-2006, 12:00 PM
I have attached to this post two .zip files that contain the two files that should fix this issue. Please extract the files and place them both in your InstallShield 12 Beta2 System folder and then re-launch the IDE.

Christopher Painter
04-19-2006, 07:48 AM
Thanks, that fixed it! 47 days left in my eval again.

lysemose
04-20-2006, 02:50 AM
Replacing ISUIServices.dll and IsSvcInstISUIServices.dll fixed the license problem on my machine and I will now start testing IS12 Beta 2.