PDA

View Full Version : Files Not Un-Installing ?



double_adam
04-11-2006, 03:59 PM
When I uninstall my program, not everything is being uninstalled?

Here is what I'm seeing:

All of the shortcuts, except the shortcut to the actual program are removed.

All of the files are remaining in the INSTALLDIR. I can still run the program after uninstalling?


Can someone please help me out? I have no idea why this is happening? I have built a bunch of installs just like this one, but never had this issue?

Sanchivan
04-11-2006, 04:26 PM
For Each component that you have created, you need to set one fo the files as the Key File. InstallShield uses this to uninstall.

Sanchivan S.

double_adam
04-12-2006, 11:31 AM
I have key files set for all of my components. The actual program itself is set as a key file, but this isn't uninstalled.

I could be wrong but I don't think this is my problem.

Thanks for your effort though!

double_adam
04-12-2006, 02:20 PM
/bump......

Buddy Jain
04-13-2006, 12:43 AM
How you are uninstalling your application... can you put some light so that I can help you on this...

double_adam
04-13-2006, 08:11 AM
Ok I will try to elaborate as much as I can. I have a basic msi project which installs a couple drivers, some files(pdf's and such), and an application. When I build and install the setup, there are no errors or warnings. The build does include a major upgrade, for existing versions already in the field.

I have tried uninstalling using the setup.exe and add/remove programs. I have tried uninstalling after upgrading, and I have completely uninstalled the program(manually deleted all the files) and then installed it. Again, when I uninstall some files are left.

The strange thing is, the drivers are uninstalled, 3 of the 4 shortcuts I created are removed from the desktop. The actual application shortcut is the one left on the desktop, and the Start Menu has the same shortcut left. Also, most of the files are still in the INSTALLDIR. All of the extra pdf's and things I install are gone, but the actual program remains installed, and I can run it from the shortcut left on the desktop or from the Start Menu.

It is almost as if anything I have set as a key file isn't uninstalled, which seems counterintuitive to my slim understanding of Installshield.

I appreciate any help you may provide. I have been searching for info, but can't seem to find anyone else having this same issue.

Buddy Jain
04-17-2006, 10:49 PM
hmmm...

It seems sequencing is not correct and due to that this is happening. Go to InstallExecuteSequence table and set few values..

Make sure 'RemoveExistingProducts' value is less than installInitialize.

It should be like this... if InstallInitialize value is 1100 then value of RemoveExistingProducts should be 1050.

Let me know if it works for you. Good luck :)

double_adam
05-15-2006, 02:17 PM
My installInitialize is: 1501.

My removeExistingProducts is: 1410.

The problem must be something else?

Thanks for your effort.

PMauger
05-16-2006, 07:29 PM
I don't know how you're build process is going but I have been experiencing a similar issue since I had to redo most of my project (after the check in function of installshield failed to check my project in and a subsequent get latest took me back 4 weeks). Despite having the project back to where it was (I think...) it simply won't upgrade my previous versions and since then the uninstall has been leaving files all over the place. :confused:

Sorry this doesn't really help but I thought some more ideas on a possible cause might steer us in the right direction.