PDA

View Full Version : Maintenance



jweber
04-05-2006, 09:13 AM
When I attempt to reinstall my product, the following occurrs:

Preparing to install ->
Some dialog flashes very quickly ->
Install Dialog with progress bar ->
SetupCompleteSuccess ->

The Maintenance Welcome sequence is never entered. I have double checked all my conditions but still cant get it to work.

PatchWelcome is PATCH And Not IS_MAJOR_UPGRADE
InstallWelcome is Not Installed And (Not PATCH Or IS_MAJOR_UPGRADE)
SetupResume is Installed And (RESUME Or Preselected) And Not PATCH
MaintenanceWelcome And Not RESUME And Not Preselected And Not PATCH

Can anyone suggest anything else to check to either get maintenance to work or to force the user to reinstall, the whole thing.

Thanks

J

RobertDickau
04-05-2006, 09:43 AM
Does creating a log file tell you anything?

(As an aside, re-running an installer from the InstallShield environment by default uninstalls the previous version, though you can change this under Tools > Options > Preferences. That wouldn't explain skipping to the progress dialog box, though.)

jweber
04-05-2006, 10:23 AM
After triple checking, all seems to be working normally... Shoo....!

However, when I choose remove from the maintenance dialog many files are not uninstalled.

Some seem .NET related, however some are just regular html files. For instance, I have the following files left:

web.xml
DateTime.asmx
Glossary.html
System.configuration.dll

I am not packaging .NET at all, and currently these files are not attached to Virtual directories in IIS. Any ideas?