View Full Version : Failed to Initialize script support, Error = 0x80040155

03-29-2006, 04:13 AM
InstallScript custom actions are not executed during setup runtime.
Heres the log:

Aktion beendet um 10:50:17: LaunchConditions. Rückgabewert 1.
MSI (c) (F0:F8) [10:50:17:846]: Doing action: ReadProfileBat
Aktion 10:50:17: ReadProfileBat.
Aktion gestartet um 10:50:17: ReadProfileBat.
MSI (c) (F0:20) [10:50:17:924]: Invoking remote custom action. DLL: C:\DOCUME~1\bm\LOCALS~1\Temp\MSIE.tmp, Entrypoint: f20
1: Running InstallScript function f20
1: Installing engine...
1: IS: Using product language 0
1: IS: Extracting support file setup.inx to C:\DOCUME~1\bm\LOCALS~1\Temp\{4022AAA0-A478-492A-BCE8-EC403174DF5C}\setup.inx
1: IS: Extracting support file ISRT.dll to C:\DOCUME~1\bm\LOCALS~1\Temp\{4022AAA0-A478-492A-BCE8-EC403174DF5C}\ISRT.dll
1: IS: Extracting support file _isres0.dll to C:\DOCUME~1\bm\LOCALS~1\Temp\{4022AAA0-A478-492A-BCE8-EC403174DF5C}\_isres.dll
1: IS: Failed to extract file _isres0.dll. Error = 0
1: Setting script cmdline...
1: ProductCode is {503952A5-00D2-41F3-A4BF-77474C4878C0}
1: Initializing Engine
1: Marshalling the , error = 0x80040155
1: Open Script operation failed, error is 0x80040155
1: Failed to shutdown script engine for script C:\DOCUME~1\bm\LOCALS~1\Temp\{4022AAA0-A478-492A-BCE8-EC403174DF5C}\setup.inx, error is 0x80070057
1: Initialize() Failure, Failed to Initialize script support, Error = 0x80040155
Aktion beendet um 10:50:18: ReadProfileBat. Rückgabewert 1.
MSI (c) (F0:F8) [10:50:18:065]: Doing action: SetupInitialization

Any suggestions what to do ?
Thank you


03-29-2006, 11:47 AM
Error 0x80040155 is Interface Not Registered. That suggests to me that we're failing to register something, and that it fails before it gets to your code. Obviously not a long term solution, could you try registering a copy of IsBE.dll on your test machine with regsvr32 and see if that lets you get past this problem?

Other information that would be useful for us to diagnose and fix this case are: what OS you are testing on, what privileges you are testing with (admin, limited, or elevated) whether this a Basic MSI or InstallScript MSI, where the failing action is sequenced, and what the settings (immediate, deferred, etc.) on that action are. And of course whether manually registering a copy of IsBE.dll works around the problem.

03-30-2006, 05:55 AM
I put the ISBE.dll on my testing machine and registered ist. It doesnt solve the problem.
Here some dates:
Build machine: Windows Server 2003 plus security updates
Testing machine: Windows XP Professional SP2 plus security Hotfixes
Build machine and testing machine are virtual machines (VMWare)
Project: Basic MSI project with installscript custom actions.
Custom action: InstallScript custom action, immediate execution, first action should be executed in the user sequence after LaunchConditions and before SetupInizialization.
User rights on testing machine: domain admin


05-17-2006, 06:32 PM
Was there any resolution to this problem? I am experiencing the same error. My test environment is also the same as Barbara's, using vmware images for testing and developing. I also tried registering IsBE.dll on my test machine and it had no effect.

05-17-2006, 07:52 PM
Yes, this has been resolved. Replace the version of ISSetup.dll located in <IS 12.0 Install Location>\Redist\Language Independent\i386 with the one attached to this post. Rebuild your setup and you should be good to go. Let me know if you run into any problems.

NOTE: The attached .zip file also contains IsBE.dll in addition to ISSetup.dll. If you plan to run any setups using the latest engine version of ISSetup.dll on 64-bit systems, then you also need to update this file on your system before building your setup. It's located in the same folder as ISSetup.dll on the machine where IS 12.0 is installed. If you're not going to run any setups on 64-bit machines, don't worry about updating IsBE.dll as it won't be otherwise used on 32-bit machine.