PDA

View Full Version : Display of Icons in Add Remove Programs



nabhonil
03-27-2006, 10:41 PM
hi,

I am using IS11 Basic MSI project. When I donot chose an icon in the "General Information"->"Add Remove Programs"->"Display Icon", then in add remove programs I can see the SetupIcon.ico. But when I choose a different icon then only a windows folder icon is shown in Add Remove programs. When I switched to the same path as it was earlier it was still showing the same windows folder icon in Add remove programs. After changing the icons path i have saved the project. Is their anything i am missing.

Any ideas what went wrong?

Thanks
Nabhonil

TsungH
03-28-2006, 10:38 AM
What's ALLUSERS property set to during installation?

nabhonil
03-28-2006, 11:40 PM
Thanks TsungH,

The [ALLUSERS] property has to be set to 1 to display proper icons. After setting the [ALLUSERS] property to 1 solves the problem.

Thank you very much.
Nabhonil

ozziemarquez
03-29-2006, 06:45 PM
Sorry for the ignorance, but where do you set the property [ALLUSERS]?
I have the same problem as nabhonil.

nabhonil
03-29-2006, 10:34 PM
There is one dialog called "CustomerInformation" which has a option called "Install this application for". There you will find that it gives two option.

1. Anyone who uses the application (all users)
2. Only for this user ([USERNAME])

So in the next button behavior if u see you will find that they are setting [ALLUSERS] to 1.

However if your install is not using this dialog then on click of any Next button of any of the dialog set the ALLUSERS property to 1. You can go to the behavior of that dialog->choose the next button->Choose the event as [ALLUSERS]->Choose the argument as 1 and condition as 1.

If you want to know more on [ALLUSERS] values check the installshield help.

Thanks
Nabhonil