PDA

View Full Version : Visual JSharp .NET Redistributable failed



loumachado
03-27-2006, 01:38 PM
So I was trying to install and I got an error message about this pre-requisite not installing. In the Jsharp install log I spot this towards the end:


MSI (c) (CC:9C) [10:07:13:295]: Note: 1: 1708
MSI (c) (CC:9C) [10:07:13:295]: Product: Visual J# .NET Redistributable Package -- Installation failed.

I looked further up and I found this; which I think is the actual failure point in the installation:

MSI (c) (CC:E0) [10:07:02:420]: Entering MsiProvideComponentFromDescriptor. Descriptor: 0M&u@epbw8r$s*4(-op%Environment_Server>M5KDYSUnf(HA*L[xeX)y, PathBuf: F4F348, pcchPathBuf: F4F344, pcchArgsOffset: F4F2A4
MSI (c) (CC:E0) [10:07:02:420]: MsiProvideComponentFromDescriptor called for component {997FA962-E067-11D1-9396-00A0C90F27F9}: returning harcoded oleaut32.dll value
MSI (c) (CC:E0) [10:07:02:420]: MsiProvideComponentFromDescriptor is returning: 0
Info 2898. DlgTextFont, Tahoma, 1
Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action script error , : Line , Column ,
MSI (c) (CC:E0) [10:07:08:201]: Product: Visual J# .NET Redistributable Package -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action script error , : Line , Column ,

Action ended 10:07:08: CA_SetW3SvcDebugMode.C8B9BEB0_A8B5_472D_B01E_7BF2496CA25A. Return value 3.
MSI (c) (CC:9C) [10:07:08:201]: Doing action: FatalError
Action 10:07:08: FatalError.
Action start 10:07:08: FatalError.
Info 2898. DlgTitleFont, Tahoma, 1
DEBUG: Error 2826: Control Line on dialog FatalError extends beyond the boundaries of the dialog to the right by 2 pixels
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: FatalError, Line, to the right
DEBUG: Error 2826: Control BottomLine on dialog FatalError extends beyond the boundaries of the dialog to the right by 2 pixels
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: FatalError, BottomLine, to the right
DEBUG: Error 2826: Control Bitmap on dialog FatalError extends beyond the boundaries of the dialog to the right by 2 pixels
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: FatalError, Bitmap, to the right
Action 10:07:08: FatalError. Dialog created

So what can I do to get past/around this?

Mike Marino
03-27-2006, 02:46 PM
What operating system were you running this on?

Basically our setup was trying to run the J# redistributable from Microsoft and that appears to have failed.

What version(s) of Visual Studio (2002, 2003 or 2005) do you have on your system?

I can point you to a location to try to run the installation manually, but I need to your Visual Studio version first.

Thanks,

loumachado
03-27-2006, 03:06 PM
Hi Mike,
I'm trying to run this on Windows XP Professional Version 2002 Service Pack 2.

I also have Visual Stuido .Net Enterprise Architect 2003.

In case it makes any difference I already have:
Microsoft Visual J# .NET Redistributable Package 1.1
Version: 1.1.4322
Microsoft Visual J# 2.0 Redistributable Package
Version: 2.0.50727

Thanks in advance for the help.

Christopher Painter
03-27-2006, 09:49 PM
I'm hoping this doesn't pose as issue to my testing. Our development environment is not connected to the internet and I have to submit all software through security before I can use it.

Mike Marino
03-28-2006, 11:04 AM
You can by pass our .NET 1.0 install by creating the registry key...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Visual JSharp\7.0

On your machine.

Then remove the key after the installation.

The error you are getting is from the J# 1.0 redistributable. I am not sure why this would fail.

loumachado
03-28-2006, 12:34 PM
Mike the reg entry got me past that install issue.

I'm a little edgy though. I have a newer version of the J# .Net (1.1 I think; it shows up as 7.1 in the registry). Shouldn't my version fulfill the J# requirement? I'd like to see this sorted out. I have no idea what version of Studio I'll be working with when we go to our next product release and working around this is worrisome. Will there be another "version" of the beta anytime soon?

We are going to be forward compatible with this J# module, right?

Mike Marino
03-28-2006, 12:45 PM
I have a post at:

http://community.installshield.com/showthread.php?t=157810&highlight=1.0

that explains why we need 1.0.

Hope this helps.

loumachado
03-28-2006, 01:17 PM
I wasn't aware that someone else posted a similar issue on a different thread. (Nor did I realize the forum grew by so much overnight!) :eek:

Thanks Mike!