PDA

View Full Version : Installer Hangs after Welcome Dialog



mgaredia
03-22-2006, 05:11 PM
After building the media and running the windows launcher, Welcome dialog appears and even after pressing Next or Cancel button, it doeesnt do anything. ANy Ideas? I am guessing it has to be something very silly which I cannot figure it out.

enanrum
03-22-2006, 06:57 PM
Yah that seems odd!

Check out your sequence make sure nothing is in the conditions or in the swing events,(shouldn't be anything in there but check anyway), do the same with the license dialog!

If nothing seems odd, remove the Welcome from the Sequence and rebuild and run see what happens!

Regards

mgaredia
03-22-2006, 07:19 PM
I removed that dialog and then it ask me for Typical or Custom dialog and it hanged there with same problem. This happens only when I installed ISMP 11.5 on Windows XP SP1 level. I re-installed ISMP11.5 on my other development box which has XP SP2 level, media created on that machine works fine on both machines.

enanrum
03-22-2006, 07:28 PM
Could it be the JVM? Are you searching for a JVM or bundling one?

If your bundling one, obviously make sure it's the same version or higher than what you developed in! I was getting errors when using a searched JVM that was for an earlier version of JVM, like 3.1 when I developed in 4.1.2!

mgaredia
03-22-2006, 07:33 PM
I am bundlng the JVM 1.5.X by Sun Microsystems How can I know which Java am I using when developing ISMP11.5 project? In any case, I dont think I have higher version than 1.5.X on my system.

enanrum
03-22-2006, 07:36 PM
In your tools-options-Compiler Options, you should see what javac your using!

Are you doing any searches for a JVM?

dlacoste
05-26-2006, 01:07 PM
I was using JDK 1.5.0_06, now using 1.4.2_08

neither works: I get the same issue (as do many others from searching on the board)

Run installer (on windows, aix, or solaris, with JDK 1.4 or 1.5, using setup(.exe/.bin) or java -cp setup.jar run) and at the first dialog that appears, the next and cancel buttons don't seem to do anything.

The program is still running, because a window-level interrupt (hitting the close button) works, popping up the "are you sure you want to exit yes/no" dialog where the yes and no buttons _do_ work.

The odd thing (for me) is that my last build (3 weeks ago, before I went on vacation) worked fine, but now it's failing.

I'm going to keep playing with it to see what happens, but right now I have no idea what's going on.....

dlacoste
05-30-2006, 06:30 PM
I reinstalled from scratch, same results.

I can build a new installer and it works fine, but the "old" one, when run, has broken buttons: next and cancel do nothing.

So I'm going to rebuild it all from scratch and diff the differences in the files at the end (building along the way :) to see what broke it.

sumitpendharkar
06-07-2006, 12:27 PM
I am also running into the same problem, I have tried everything, still not working. I am now running out of ideas. Any other suggestions?

dlacoste
06-07-2006, 12:31 PM
I took the whole project and re-wrote it.

Fortunately I didn't have any custom beans (yet) so it only took about 6 hours, but in the end it works fine and I can't see the difference :(

sumitpendharkar
06-07-2006, 07:50 PM
Re-creating the project doesnt seem to work. In fact when I create a new project, it works the first time, and then doesnt work. Strange... Ay other ideas? Thx.

dlacoste
06-08-2006, 11:10 AM
My only "guess" (which is a very long shot) is that the XML file (the .uip file) was getting corrupted somehow: most likely from version control (or a text editor) causing the file to change from utf-8 to ASCII (or something similar)

But that's such a long shot I can't imagine it's the cause (I also haven't been able to duplicate the problem)

I wish someone from InstallShield would comment on this thread!

cimlup
06-11-2006, 02:18 PM
I've been hear before too, but can't for the life of me remember what the solution was. I've done some updating, and am suspicious of that. Team mate delivers runnable installers so it's something local.

Stay(ing) tuned

gigistan
06-12-2006, 08:29 AM
A suggestion: launch the installer from a command line.
When the wizard comes up, click next on the welcome panel. Are you seeing error messages like "doNext method does not exits" or similar in the console?
If yes, that's the problem. The default ISMP code isn;t available at install runtime. Have you modified uip projects by changing it;s default package name (com.installshield.<you-projects-name) into something or your own?

mgaredia
07-13-2006, 06:23 PM
I did notice that if a project is opened in NOTEPAD and modify, it does hang up the installer at welcome dialog.

But what I have learnt is you have keep saving the last working revision that you been working on because you never know when this will get corrupted. It may be good idea rather than writing the whole thing because there is no way you can get it working unless you rewrite it. I have not found any workaround yet.

rahall
07-17-2006, 06:12 PM
I encountered this problem when building a project from my Standalone build machine after I would disconnect from the network. My project would build successfully but at runtime would hang after the Welcome dialog.

My project was looking for the CustomCode Library files in a nonexistant location.

Check your Project settings for Event Code location (ie) I changed mine from:

Under
>General Information

>> Project Properties

>>>>Event Code Source Location
G:\Installshield 11 projects\testdialog\CustomCode\src (to) CustomCode\src

>>>>Event Code Output Location
G:\Installshield 11 projects\testdialog\CustomCode\lib (to) CustomCode\lib

Hope this was on topic and helps,
Aaron

mgaredia
09-07-2006, 05:07 PM
When you move around the *.uip file from one location to other location, you have also move CustomCode directory along with it. Also make sure General Information->project properties "Event Code source location" and "Event code Output location" are pointing correctly to customcode directory. Its always better to have relative path rather than full path mentioned there. Also one thing you need to make sure is all the *.java files under CustomCode have correct Package name at the top.

nrajabali
09-11-2006, 02:34 PM
This usually happens when the Custom Code src are not getting compiled or its not found in the path during the Media build.