PDA

View Full Version : "The Upgrade patch cannot be installed by the Windows Installer service..."



pyaire
03-22-2006, 04:27 AM
Hello guys!!
please i need an instant help form anybody!!!! am on the edge now!!!
i created an application using IS Express 11.5 n i created a QuickPatch for a file called mca.exe. The original version of my mca.exe is 6.00.0000. the patch version is 6.00.0001. the patching operation is normal and the application runs smoothly after update. but my problem is that i need to create additional patches for this file, and i have two options :
1- either to update the original mca.exe v. 6.00.0000 with a patch version 6.00.0001, then 6.00.0002... everytime by patching the original setup version.
2- or to QuickPatch the patch, it means update mca.exe v. 6.00.0000 with the patch 6.00.0001, then update mca.exe v. 6.00.0001 with 6.00.0002....
but in both ways i have a problem with skipping a version, this means that i can't update mca.exe version 6.00.0001 with the patch 6.00.0003 by using the second option, and by using the first option i can't update two consecutive versions like patching 6.00.0002 with a new version 6.00.0003 and in any case i receive the message :
"The Upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."
So as i figured it out, the problem is that the new patch is patching one and only version... and it doesn't give me any good!!!
Can someone help me with that!!!!
Thank you,

Regards,
Pierre Sabbagh.