PDA

View Full Version : Repair or Remove Not working



ramanan2
03-21-2006, 11:07 AM
Hi,
I have a windows installer project using Installshield 11.0 Professional.

The initial install of the product goes fine. When I run Setup.exe again it gives me Repair and Remove as it should. Choosing either and continuing goes to the Setup was interrupted dialog without completing the requested operation.

If I run the Remove from add/remove programs (this is the only option in add/remove programs) the product properly uninstalls.

The log file size when the initial install runs properly is approximately 3.36MB
The log file size when setup is run again with and fails is approximately 203KB

Here is the error
=== Logging stopped: 3/21/2006 10:05:42 ===
MSI (c) (18:20) [10:05:42:336]: Note: 1: 1729
MSI (c) (18:20) [10:05:42:336]: Product: [productname] -- Configuration failed.

MSI (c) (18:20) [10:05:42:352]: Grabbed execution mutex.
MSI (c) (18:20) [10:05:42:352]: Cleaning up uninstalled install packages, if any exist
MSI (c) (18:20) [10:05:42:352]: MainEngineThread is returning 1603
=== Verbose logging stopped: 3/21/2006 10:05:42 ===

Thanks.

mclark
03-22-2006, 09:54 AM
Could you post (Attach) the entire log file be sure to log with /l*v

ramanan2
03-22-2006, 12:10 PM
i have attached the log file

ramanan2
04-05-2006, 11:32 AM
Could you post (Attach) the entire log file be sure to log with /l*v

Can anyone reply to this please?

bhagelin
04-05-2006, 06:35 PM
Have you tested this issue on a clean drive (imaged drive)? Also check the General Information->Add or Remove Programs section of the InstallShield IDE -- there you have options for allowing/disallowing maintenance options.