PDA

View Full Version : To Those Getting -6645 Build Errors



bryanwolf
03-20-2006, 01:02 PM
Could anyone who is getting this error please post the following information:


1) The .NET Version and VS Project Type of your product
2) The Original InstallShield IDE in which this project was created
3) The Current Version of InstallShield you are using (Should be Express 11.5)
4) Whether you have non-.net DLLs and EXEs in your project
5) Whether you've used dependency scanner on this project
6) Whether you can reproduce in a Clean Project Created with 11.5 Express.

This would help us greatly in getting the information we have around since a lot of people have been posting different things.

Please don't post any other information in this thread unless you feel it would (Directly or Indirectly) assist in providing or explaining the above information.

Thanks everyone for working with us while we hunt this issue down!

rlangham
03-29-2006, 03:32 PM
1) The .NET Version and VS Project Type of your product

Initially .NET 1.1, I have VS.NET 2003 Installed. Once I installed VS.NET 2005, my InstallShields broke on my 2003 Projects. I was not using the .NET 2005, I just simply installed it and create a couple of simple projects to play around with, but then went back to my VS.NET 2003 projects. I then noticed that the .NET 2003 builds broke

2) The Original InstallShield IDE in which this project was created
InstallShield Express 11

3) The Current Version of InstallShield you are using (Should be Express 11.5)
I downloaded the evaluation to see if this fixed the problem. It didn't. I just tried using the IsCmdBld.exe from the new release with my current 11.0 builds.

4) Whether you have non-.net DLLs and EXEs in your project
Yes, I have an ActiveX control and several related DLLs. But, problem is occuring on the ActiveX and its DLLs as well as some of my other .NET DLLs in the project.

5) Whether you've used dependency scanner on this project
No, I do not believe I did.

6) Whether you can reproduce in a Clean Project Created with 11.5 Express.
Have not tried, too frustrated to try it

RyanSmith
03-29-2006, 11:01 PM
Hi,

1) The .NET Version and VS Project Type of your product
.NET 2.0 Window Application (Upgraded from 1.1)
2) The Original InstallShield IDE in which this project was created
Originally created in InstallShield 11 Express
3) The Current Version of InstallShield you are using (Should be Express 11.5)
InstallShield 11.5
4) Whether you have non-.net DLLs and EXEs in your project
Yes there are a few non-.net DLLs
5) Whether you've used dependency scanner on this project
I used Static scanning.
6) Whether you can reproduce in a Clean Project Created with 11.5 Express.
Yes, I tried running it on a new .NET 2.0 Windows Application and added some third party .NET references and it still throws 6645 errors (for kernal32.dll, security.dll, gdi32.dll, uxtheme.dll, user32.dll). I completely reinstalled installshield 11.5 but I am still having the same problems. It seems to throw this error on about 80% of the third party dll I added. Some of the dlls that generated this error include the Oracle DataAccess component and the VB.NET Power Pack which you can get off the Microsoft website and thet references are a mixture of .net 1.1 and 2.0. The only thing I can think of that might be different to the test environemtns is that I am running both VS 2003 and 2005 on my machine, but I have set the .NET settings to point to the .NET 2.0 tools.

Thanks

Ryan

mittelhauser
04-11-2006, 05:29 PM
For what it is worth, I also run both VS2005 and VS2003.

Is there any progress on this? I can't wait indefinetly...

-Jon

JCUNNINGHAM
03-06-2007, 05:52 PM
has a fix been published for ISS 11 Professional???

destek
07-23-2007, 03:26 PM
1. .net 2.0
2. InstallShield Express 11.5
3. Yes (dll in the System folder) and Yes (a support EXE with the application)
4. I did not at first, but running dependency scanner did not help
5. I built the project with the problem from scratch

Des

destek
07-23-2007, 03:54 PM
Ok - not sure why they even keep these old threads around - especially when they rank higher than the actual RESOLUTION to the problem in the site search....

But - here is a link to the resolution

http://support.installshield.com/kb/view.asp?articleid=Q112146

It's a simple fix.

collinsauve
10-20-2009, 10:25 AM
Where's the fix for 11 Pro?????

1) The .NET Version and VS Project Type of your product
.Net - Some 2.0, Some 3.5

2) The Original InstallShield IDE in which this project was created
InstallShield 11 Pro

3) The Current Version of InstallShield you are using InstallShield 11 Pro

4) Whether you have non-.net DLLs and EXEs in your project
Yes

5) Whether you've used dependency scanner on this project
No

6) Whether you can reproduce in a Clean Project Created with 11.5 Express.
Have not tried, too frustrated to try it.

:mad: