PDA

View Full Version : NullPointerException



-=|Timo|=-
03-14-2006, 09:12 AM
Hi,

I get the following exception when I open Add-in Manger the first time when I opend the project

Cannot display view because the following error occurred:

java.lang.NullPointerException at com.installshield.isje.project.ProjectView.setCurrentView(Unknown Source) at
com.installshield.isje.project.ProjectView.viewChanged(Unknown Source) at com.installshield.isje.project.ViewListView.valueChanged(Unknown Source) at
javax.swing.JTree.fireValueChanged(Unknown Source) at javax.swing.JTree$TreeSelectionRedirector.valueChanged(Unknown Source) at
javax.swing.tree.DefaultTreeSelectionModel.fireValueChanged(Unknown Source) at javax.swing.tree.DefaultTreeSelectionModel.notifyPathChange(Unknown Source) at
javax.swing.tree.DefaultTreeSelectionModel.setSelectionPaths(Unknown Source) at javax.swing.tree.DefaultTreeSelectionModel.setSelectionPath(Unknown Source) at
javax.swing.JTree.setSelectionPath(Unknown Source) at javax.swing.plaf.basic.BasicTreeUI.selectPathForEvent(Unknown Source) at
javax.swing.plaf.basic.BasicTreeUI$Handler.handleSelectionImpl(Unknown Source) at javax.swing.plaf.basic.BasicTreeUI$Handler.handleSelection(Unknown Source) at
javax.swing.plaf.basic.BasicTreeUI$Handler.mousePressed(Unknown Source) at java.awt.AWTEventMulticaster.mousePressed(Unknown Source) at
java.awt.AWTEventMulticaster.mousePressed(Unknown Source) at java.awt.Component.processMouseEvent(Unknown Source) at
javax.swing.JComponent.processMouseEvent(Unknown Source) at java.awt.Component.processEvent(Unknown Source) at java.awt.Container.processEvent(Unknown
Source) at java.awt.Component.dispatchEventImpl(Unknown Source) at java.awt.Container.dispatchEventImpl(Unknown Source) at
java.awt.Component.dispatchEvent(Unknown Source) at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source) at
java.awt.LightweightDispatcher.processMouseEvent(Unknown Source) at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source) at
java.awt.Container.dispatchEventImpl(Unknown Source) at java.awt.Window.dispatchEventImpl(Unknown Source) at java.awt.Component.dispatchEvent(Unknown Source) at
java.awt.EventQueue.dispatchEvent(Unknown Source) at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source) at
java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) at java.awt.EventDispatchThread.pumpEvents(Unknown Source) at
java.awt.EventDispatchThread.pumpEvents(Unknown Source) at java.awt.EventDispatchThread.run(Unknown Source)

the second time it seems all will work fine. I can now register my own custom beans. But when I will use them in sequence or n feature explorer I can add them but noch configurate them. I cannot click on my own bean, IS will hung a second. Working with all other is fine.

In past I do some possible mistake.
I renamed a custom bean. Before I opened IS and register the renamed custom bean, I deleted the old one in Project.uip with an texteditor.
There is no other problem but with my own beans it do not work.

How can I fix it ?
Where can I find an log or something similar ?

Timo

-=|Timo|=-
03-14-2006, 11:35 AM
okay, my beans are working now, but the first-time-nullpointerexception is still there ...