PDA

View Full Version : New to InstalledShield and having difficulty, can anyone help?



jackylad
03-08-2006, 12:11 PM
Hi Everyone,

I've just bought InstallShield Express 11.5 but I'm not experienced in making installers, and in fact I've only ever packaged up an installer using ZINC, a flash .exe application builder. Maybe I've bought something that is too complex for me??? The help files are hard to follow IMO.

Anyway, I'm trying to do a pretty simple installer concept as follows:

1. I've got an interactive training application (Macromedia Director) that requires the user to have the Indeo Codec 5.10 installed to view the video footage. I'm sure that this codec is installed as standard with XP machines but I need to make sure either way, as it is for distribution to users on corporate networks.

2. I've got two folders with dependant files for example the Icon and the Xtras for Director.

3. My Director application has a function that re-sizes the users screen resolution to 1024 x 768. (Don't know if there is some way of making that happen through the installer on an ongoing basis??? As in each time it runs from the PC.)

4. I want the Application to run from the end-users PC and don't need to alert about things like upgrades.



I seem to be stuck with three problems:

1. The installer that I have made, which doesn't check that the end-user has the codec, takes ages to install. The application id 400MB in total but it can take up to 3 minutes for the extraction bit to complete never mind the install! Is that right???

2. I can't figure out the best way to ensure that the end-user has the Indeo Codec 5.10 installed. I've looked on the threads that discuss the System Search Wizard but I don't fully understand it, is there an idiots guide somewhere, video tutorial????

3. I've created some custom .bmps for the installer but can't figure out how to get them to display at the point where the installer is unpacking the set up files. (I think :confused: ) It does display my .bmps once the application install starts though. Maybe you can't customise the first bit?

I hope someone can spare the time to give me a few pointers.

:) Cheers