PDA

View Full Version : How can I disable "Preparing to install" dialog ?



JohnInSoCal
03-01-2006, 09:51 PM
This is using InstallShield 11, MSI basic and the bootstrap exe loader is displaying this dialog.

I have searched the KB & forums and found several suggestions but none seem to work for me. If I can't disable the dialog I would like to change the application name post build, possibly using setupini.exe

I tried using setupini.exe to modify the setup.exe after building the install to add "UI=0" However after running setupini.exe the setup no longer functions, no errors, just nothing happens. Does setupini.exe work with InstallShield 11 ? I found 2 different versions of setupini.exe on the IS site, however neither worked. Both report success in modifying the setup.exe however when I run the older version of setupini I get an error when running setup.exe saying the ini is corrupt. When I use the newer setupini.exe nothing is displayed when I run setup.exe

I also tried to edit the setup.ini located under

c:\program files\installshield 11\support\msi1.2 to add "UI=0" to the [Startup] section, no effect.


thanks,
-- john

JohnInSoCal
03-01-2006, 10:37 PM
well I found a solution, this version of setupini.exe works with InstallShield 11. I'm not sure if there is another solution to this problem.

http://www.installsite.org/pages/en/msi/isd.htm

Here is the ZIP file
http://www.installsite.org/files/iswi/SetupIniExe105.zip

Ariel Gomez
08-11-2011, 12:12 PM
I could find a solution to disable initialization dialog after rebooting, and it worked for me,
you need adding the next command line to run the setup from runonce or from some bat file:
Setup.exe /hide_progress

during hide progress it is showed the ishield icon on the taskbar