View Full Version : Installation unsuccessful in Pocket PC

02-07-2006, 10:27 AM
When upgrading an existing application in Pocket PC, I get an error "Installation was unsuccessful". This doesn't happen all the time and it happens only in 5.0 devices.

I tried signing the cab file and installing it again. Still I get the same error.

Any suggestions would be of great help.


02-10-2006, 01:52 PM
I have never personally run into this error. Perhaps the files that are being uninstalled are locked somehow? Are you uninstalling via the ActiveSync Add/Remove programs on your desktop?

02-14-2006, 12:43 AM
I am ugrading the setup cab file using the procedure I have given in the post
"ActiveSync Add/Remove programs", located in the same place as this thread.

Is this a problem? I am using the CAB file genereated part of the build by the InstallShield and storing the CAB file part of the Support Files/Billboard. I think this cab file is complete and can be directly downloaded into the device for installation.

I run into this problem only in 5.0 device only. this happens only in certain procedure such as registry is modified in the application and then initiate Upgrade process.

If there is anything wrong in the procedure for reinstalling, please let me know.

Thanks & Regards,

02-15-2006, 12:56 AM
I am also including the log file that is generated during installation process.

Please review the log file. I was not able to understand the log file.

Thanks & Regards,

02-15-2006, 01:00 AM
Sorry forgot to add the attachment :)

Error reporting tag
<characteristic-error type="Install"><parm name="InstallPhase" value="install"/>
<parm name="SetupDLL" value="1"/>
<parm name="ProcessorType" value="2577"/>
<parm name="OSVersionMin" value="4.20"/>
<parm name="OSVersionMax" value="4.99"/>
<parm name="BuildNumberMin" value="0"/>
<parm name="BuildNumberMax" value="-536870912"/>
<parm name="UnsupportedPlatforms" value="HPCPALM PC2JUPITER"/>
<parm name="AppName" value="SlingPlayer Mobile"/>
<parm name="InstallDir" value="\Program Files" translation="install"/>
<parm name="NumDirs" value="6"/>
<parm name="NumFiles" value="157"/>
<parm name="NumRegKeys" value="0"/>
<parm name="NumRegVals" value="0"/>
<parm name="NumShortcuts" value="1"/>

02-15-2006, 06:16 PM
What happens if you manually run the cab file on the device? Do you still get the error even if you place the cab file on the device and double click it? I need to know if this is a bad cab file or related to ActiveSync somehow.

02-16-2006, 09:10 AM
Hi Davidh,

If the cab file is launched manually, then it installs properly.

My senior colleague seems to have confirmed that it is a bug in WM5 devices (It is reported in msdn site). I was not able to get the reference URL. Can u also confirm that this is an bug?

Is there any way that this can be fixed? We are in the last phase of the release if there is any quick fix, then we'll appreciate it.

Thanks & Regards,

02-16-2006, 09:21 AM
I posted this error in Microsoft forum site also. One person has replied that this error may be due to the OS version (See below) reported in the error log file (attached previously)

<parm name="OSVersionMin" value="4.20"/>
<parm name="OSVersionMax" value="4.99"/>

It say the max version is 4.99, can this be a problem for WM5 devices?

Is there a way in InstallShield to modify this OS Version?

Any ideas!!!!

Thanks & Regards,

02-17-2006, 08:44 PM
I have encountered the same problem, it only happens with Windows Mobile 5.0 devices.

The settings I used to generate the CAB file are:

UnsupportedPlatforms="HPC","HPC Pro"

Any idea on how to solve this?


02-27-2006, 02:19 PM
Did anyone solve this error? If so, I believe a solution might be useful to other customers. I was looking around MSDN because it was mentioned earlier in the post that this might be some sort of known issue with Windows Mobile 5. I couldn't find anything specific. It seems that this could be related to digital signing of your files though.

02-28-2006, 02:45 AM
No, the problem still remains......

It is not due to digital signing. I tried signing my application with Sample Developer certificate provided by Microsoft (SDKSamplePrivDeveloper.cer). I signed the CAB file and started the installation process. Then also it failed.

I doubt Setup dlls. The setup dlls installed along with the application is stored in the following directory "\Windows\AppMgr\<Project Name>" and the name of the dll file is mangled. After the installation is complete this dll must be unloaded but still it remains in memory(Cannot be deleted manually). I doubt this might cause problems during upgrade (existing setup dll in use, unable to copy latest dll, guessing..... :) )

Any Ideas.....


03-02-2006, 01:38 PM
It is a bug in WM5.

There seem to be some work-arounds but none of them seem great to me.

This discussion sheds some light on it:

Synopsis in case the above link goes bye-bye:
The installer scans the Cab file, and, if it finds an executable, it looks through all running processes for a match. This process takes up a lot of RAM (more than it should) and if it doesn't find enough RAM to do the job it will fail.

End user should do a soft reset before installing/upgrading
rename the .exe extentions in your cab files and have a setup.dll name it back to .exe after the install.

It sounds like this bug has been fixed for future builds of WM5

03-03-2006, 12:32 AM
Thanks for the reference :)