PDA

View Full Version : java.lang.NoClassDefFoundError problem



CRA_TOD
01-06-2006, 12:23 AM
Hi,

I been using InstallAnywhere for almost two years now for our application. I'm converting the installer to use InstallShield Multiplatform 11.5 Premier edition instead. I created the new package and installed my application. All the files are there. When I run the application I always got the following error: "java.lang.NoClassDefFoundError: ca/gc/ccra/tod/tierc/main/Main Exception in thread :main"

I'm running win XP sp2
I bundled the "windows-sun-1.5.0.exe" with the application.

The launcher option
- Main class : ca.gc.ccra.tod.tierc.main.Main
- Class Path : "$P(component1.absoluteInstallLocation)"

I add the class files to the folder classes. I try with a jar file but I have the same error.

I did some research on the net but I could not found anything related to my problem.

Can you help me? Any help would be greatly apreciated.

enanrum
03-13-2006, 03:05 PM
Did you ever get this resolved, I'm getting the same error! Basically opened my 10.5 project in 11.5 and tried to compile it!