PDA

View Full Version : Product bean key does not exist error



jojigt
12-22-2005, 10:09 AM
I have a custom wizard bean that checks for installed features. Strangely, resolveString for the code-
String uid = wizardsvcs.resolveString("$P($P(" + beanId + ").key.uid)");
returns the following ERROR: product bean key does not exist

The project has been migrated from MP 5 to IS 11 and now to IS 11.5. This used to work before.

Any pointers would be helpful?

Regards,
J. George

RobertDickau
12-28-2005, 12:09 PM
How is your beanId variable defined/initialized?

jojigt
01-03-2006, 07:58 AM
The beanId is defined through a setter method. I have tried outputting the beanIds and they all seem ok.

FYI, the support from Installshield has informed us that this is a bug in IS 11.5.

jeejay
01-26-2006, 03:07 PM
I encountered the same problem. Is there a workaround on this issue? Does anyone know when this bug will be resolved?

Thanks.

jojigt
01-27-2006, 08:57 AM
I did the following workaround for my project:

ProductService service =(ProductService)this.getService(ProductService.NAME);
Object key = service.getProductBeanProperty(ProductService.DEFAULT_PRODUCT_SOURCE,
beanId, "key");
uid = ((SoftwareObjectKey)key).getUID();


Hope this helps.

Regards,
Joji George

Jeff Morse
02-08-2006, 02:36 PM
I also encountered the same problem. In a 10.5 Universal project these product bean property string resolvers worked:

$P($P(beanId).key.version.major)
$P($P(beanId).key.version.minor)
$P($P(beanId).key.version.maintenance)
$P($P(beanId).key.version.update)
$P($P(beanID).key.version.formatted)
$P($P(beanId).key.UID)

but they don't work in IS 11.5 MP. I found out that $P($P(beanId).key) gives you a string with the same info:

uid = a32333bbe4ce058c74ac6ddd4aca0595 : version = 1.2.3.4 : instance = 0

but I would prefer it if I didn't have to write the java to get the tokens I want.

What properties should I use in string resolvers to give me the version and/or UUID strings? Also, where is that information available? I searched the help for examples but couldn't find this.

Regards,

Jeff