View Full Version : Error while configuring IIS

11-30-2005, 11:18 AM
I am working on an installer that needs to configure IIS to enable a web app. If I only copy the files to the C:\inetpub\wwwroot\app\ folder (Specify Application Data>Files) the installer works fine.
But when I try to configure the IIS (Configuring Your Target System>Add new web site and then add new virtual directory...) to enable the app and I run the installer, the following message appears:

"The wizard was interrupted before [appname] could be completely installed. Your system has been not modified. To complete installation at another time, please run setup again "

It happens always when I try to add a virtual directory... Any idea on what could be happening?

12-01-2005, 06:48 AM
The project I was trying to build was an old project that needed some changes and was built with an old express edition of Installshield. The IS Express 11 detected that, and upgraded my project but I think it didn't worked fine because I wasn't able to create any virtual directory without having the problem described above.
I have rewritten the project with the new IS and all worked fine. I solved the problem but this solution is not very good. I was able to do this because the project was small. Any ideas on what happened or what could I do if it happens again with a bigger project?

12-05-2005, 02:00 PM
The error provided is very general, it just says the wizard was interrupted. Most likely there would be a more specific error in the log. You would log the install and go from there...