PDA

View Full Version : Problem Launching IExplore.exe from Install



Jonny_B
11-11-2005, 10:40 AM
I'm having a problem using a custom action to launch IExplore.exe [URL], it is loading in "Compatibility Mode", is there any way around this? Here are my settings for the custom action:

Executable Filename: <ProgramFilesFolder>\internet explorer\iexplore.exe
Commandline : [URL]
Return Processing: Synchronous (Check Exit Code)
In-Script Execution: Immediate Execution
Executing Schedule: Always Execute

Thanks for your help!

Jonny_B
11-11-2005, 11:24 AM
I noticed that when the process is running, it runs as MSI##.tmp, not iexplore.exe, so I'm not sure if I even have any control over this .... really strange.

Jonny_B
11-11-2005, 11:56 AM
I think that I am going to have to evaluate either

ShellExecute(...)

or LaunchApp or LaunchAppAndWait(...)

does anyone know anything about either of these methods? Do you know how I can retrieve properties from the property table and put that value into this function? Thanks

RobertDickau
11-11-2005, 12:10 PM
It seems your custom action type might be launch-an-EXE stored in the Binary table, which means iexplore.exe is being copied from your build machine into the MSI database, then expanded to a temporary file at run time. Perhaps explore the other launch-an-EXE options, such as launching iexplore.exe from a directory in the Directory table or from a path stored in a property?

Jonny_B
11-11-2005, 12:33 PM
Thanks for your help Robert,

I changed my custom action to a directory path, so I made a path called "IEPATH" which points to C:\Program Files\Internet Explorer

I am calling the executable iexplore.exe

Now, if I set up the call to be synchronous it gives me an error 1721, which says that the file cannot be found. If I run it asynch, it doesn't do anything?

Any thoughts? Thanks for your input.

RobertDickau
11-11-2005, 12:54 PM
Did you add IEPATH to the Directory table or to the Property table? It might want to be the former...

(As an aside, unless all your target systems are identical you might want to set up a system search that populates a property that contains the path to iexplore.exe, and then use that property in your custom action.)

Jonny_B
11-11-2005, 01:38 PM
I just created a search to look for iexplore.exe and then store it in IEPATH (which is a property). It still says that the file cannot be found, not sure what it is doing still.

RobertDickau
11-11-2005, 01:54 PM
Hmmm... A quick test seems to work for me... First, create the system search:
File name: iexplore.exe
Look in: full path: [ProgramFilesFolder]
Max number of subfolders: 3
Store value in: IEPATH
Then create the custom action:
New EXE > Path in property value
Executable property: IEPATH
Command line: http://www.macrovision.com
Install UI Sequence: After SetupInitialization
It launches Internet Explorer with the Macrovision home page...

Jonny_B
11-11-2005, 02:05 PM
Thanks a lot Robert,

my problem was that the property IEPATH was not working properly, I changed it to IEXPLORE and it worked fine (not sure why the change was needed). Now my problem is that I am trying to verify the MSI package,and I am getting a lot of errors. Not sure what to do about these ... but I'll look into these.

Thanks again Robert.

Jonny_B
11-11-2005, 02:24 PM
I'm getting a lot of errors regarding per-user and per-machine installs. I want this to be a exclusively per-machine install, so I made the property ALLUSER = 1, so it will automatically install as a per-machine install. Now, it is saying that it contains both properties of a per-machine and per-user. Does anyone know how to fix this problem?