PDA

View Full Version : Basic MSI - Large installation hangs or get error 1311



AnnikaL
11-02-2005, 08:45 AM
Hello,
I have created a Basic MSI project since this is supposed to be the only project which supports Billboard controls.
Now, I got it to work while I used some small temporary files instead of the files I really want to install. The reason I used these instead before is because building a project is HORRIBLY slow! Anyway... now that I added my 3.9GB total files I get problems.
On my own computer (using WinXP) I start the installation and it comes to the welcome screen where it just hangs. When a co-worker (also using WinXP) is starting the install on his computer he can start the installation but the billboard images just flash by (these were working with the small files) and then he gets:
error 1311. Source file not found: F:\ARCHIV~2.cab
The cab-file is there.
I have searched ALOT for info on this, but none of the suggested things have worked. My co-worker is logged in as admin so that's not the problem (as some threads suggested).
I've used One Cab Per Component and made sure that no component has as much as 2GB of size.

Trial and error is NOT an option as it takes me 3 hours to build the project.

AnnikaL
11-02-2005, 11:51 AM
After deleting everything from the DISK1-folder and then building the project again it worked for me, but my co-worker still gets the same error code.
Also, one thing was still strange for me. It told me it couldn't find 3 of the files at the end of installation (I could still continue by choosing Ignore but the files didn't transfer). All 3 files were in the same directory, but when it told me they did not exist at the specified location it gave me the location where they actually existed.. These files were not compressed. They were just 3 .url files that were put inside a folder on DISK1 and were to be transfered to a folder in the StartMenu with the same name as the folder they were put in at DISK1.

Supposed to have everything working tomorrow, but right now it seems it will take forever.

AnnikaL
11-03-2005, 12:22 PM
Turns out InstallShield gives one of the cab-files the wrong name while packing... Smells bug to me. I renamed a file called ARCHIV~11.cab to ARCHIV~2.cab and everything goes well.
Until...

Launching the setup.exe after the game is installed (to repair or remove) just starts the InstallWizard, but then it hangs before you can do anyhting.
Same thing happens if I click the Uninstall shortcut.

Any ideas at all?

davidh
11-04-2005, 05:58 PM
Logging the setup would help a lot here. You might get a specific error in the log or at least the step that the install is hanging on.

Also, I would be very interested in how you can reproduce the possible bug so we can get it fixed! Thanks for reporting this, but at this point I think we need a little more info.

AnnikaL
11-07-2005, 09:55 AM
Thank you for answering.
The rather long log just tells me what it's doing, like Building Cab files... etc.
It doesn't give me any information more than what it's currently working on, and it ends with:
DVD5_MIXED_COMPRESSIONS - 0 error(s), 0 warning(s)
so whatever goes wrong it seems InstallShield doesn't know of it.
At the start of the cab-building it tells me:
Building CAB files...
ARCHIV~1.cab built
ARCHIV~11.cab built
Then it goes on with other cab-files with names like:
_C0279~1.cab built
_47D44~1.cab built
_A39CF~1.cab built
and a bit down the list continues with
ARCHIV~3.cab built
For some reason it names the second ARCHIV~# to 11 instead of 2, which to me sounds like it hasn't properly finished with ARCHIV~1 yet, but it's just a guess. The strangest thing is that InstallShield gives the cab-file this name, but when you install it's expecting it to be named ARCHIV~2.cab.
My workaround for the moment is to manually renaming it after every re-build.

I still have the problem with the Installer hanging on Uninstall and Repair (does the same thing to my co-worker now.. no ERROR #### anymore for him). I wonder if this could have anything to do with the fact that I removed the Modify-radio-button? I've tried to remove any references to "modify" and "change", but still hangs. This problem is much more urgent since I see no workaround for it, so I would appreciate any answers on this.

Edit: Something that would probably help me with finding out the problem would be if the MSI Debugger didn't hang InstallShield EVERY SINGLE TIME, regardless of how I quit the installation.

AnnikaL
11-07-2005, 11:47 AM
New info...
I was trying to Debug and got to the place where Repair hangs everything, which is right after the MaintenanceWelcome dialog when I click Next after choosing Repair. This is also where my co-worker reports that it hangs.
Anyway, since the Debugger always hangs InstallShield when I stop debugging, I wanted to check some things before shutting it down. And after a while the ReadyToRepair dialog showed up! So it seems like it doesn't really hang everything but rather is EXTREMELY slow. I must've waited for at least 10-15 minutes (and the Task Manager says that the installer is not responding).
Any ideas on what this might be because of?
Seems to me that it's happening while Installshield is performing the events:
[ProgressType0] | Repair | _IsMaintenance = "Reinstall"
[ProgressType1] | Repairing | _IsMaintenance = "Reinstall"
[ProgressType2] | repairs | _IsMaintenance = "Reinstall"
[ProgressType3] | repairs | _IsMaintenance = "Reinstall"
that are the first 4 lines on the "Next" button.

After the long long wait it popped up the ReadyToInstall dialog, and when I clicked next it went into initializing the repairing which was also VERY slow. I looked at the window now and then to check how far the progress bar went. It went really slow, but then it suddenly popped up the Finished screen so it seems that the Repair process itself didn't take any time at all.. just the initializing.

As I mentioned before, my install contains 3.9 GB of cab-files so I wonder if this has anything to do with it? I've seperated them into cab-files that are all less than 2 GB and I've confirmed that I don't have more files than the maximum number. It's unacceptable to have it be slow enough to make the user think it hangs. Is there anything I could do to make things proceed at an acceptable speed (which it does while installing)?

davidh
11-07-2005, 02:28 PM
I believe the repair mode might be hanging because of the modification you made to the maintenance dialog. I don't think you can just remove the button. You might try hiding it instead? MSI dialogs, unfortunately, can be very trickey and sensitive. You can verify that this is the case by restoring the maintenance dialog to its original state.

The log I was referring to was the setup log captured during the installation, not the build log. Sorry for any confusion.

AnnikaL
11-21-2005, 04:37 AM
Okay.
Took me a while to find this reply since it's hard to find replies within replies here. Gonna check that thing.

AnnikaL
11-21-2005, 10:59 AM
Please look here for info from the log during installation:
http://community.installshield.com/showthread.php?postid=336490#poststop
And please post the reply to the original post instead of a sub-post, because when you reply to a sub-post that reply is hidden when you view the original post.