PDA

View Full Version : dotnetfxsp1.exe not found



Wilbur
11-02-2005, 03:51 AM
Just upgraded from IE 4 to IE11.
When I build the project, I get en error -6247: "The .NET Framework redistributable [path]\dotnetfxsp1.exe is not found on the system...".
My project does specify to include the .NET Framework 1.1.

Seriously, after trying all the steps listed below I'm not impressed and am close too demanding a refund. What next do I try???


So far I have done the following:
1) As the rest of the error message said, I have downloaded the .NET Framework 1.1 English SP1 for Windows 2003 using the InstallShield "Redistributable Downloader".
2) Worked through InstallShield article/Document ID: Q109101 "ERRDOC: Build Error 6247" (which we were referred to by the original error message. And we noted that the article has not been reviewed for the current version!). We found none of the causes are the cause in this case and none of the resolutions resolved the problem.
3) Looked up and tried the relevant messages in the InstallShield community:
a. I have removed files from the \InstallShield 11 Express Edition\Redist\0409\i386\ location and re-downloaded the files. The file 'dotnetfxsp1.exe' was not installed to the required location!
b. I then tried downloading the redistributable direct from Microsoft's website and located it in that folder, then re-down-loaded the files. It still does not work! So now I've gone back to the original files after the InstallShield download, and have the following files:
_IsRes.dll, _isresce.dll, Readme.rtf, vjredist.exe,
dotnetfx.exe (306KB),
1033dotnetfx.exe,
1033dotnetfxSp1.exe
4) Installed IE11 on a different machine, and still the same problem!!!
5) Tried with a new project and an upgraded project.
6) Tried specifying that the project only be installable on Win 2000 and XP, but not 2003.

MichaelU
11-02-2005, 01:00 PM
Hi Wilbur,
The redist "1033dotnetfxsp1" is the Windows-2003 version. You want to download the "SP1 for pre-Windows 2003 Machines" which is "dotnetfxSp1".

Wilbur
11-02-2005, 10:50 PM
Thanks Michael. Its easy to overlook that option! I wish I'd asked before.

I put in a suggestion that this kind of info be added to KB Document ID: Q109101.

Jim Tanner
11-24-2005, 06:31 PM
I have the same problem. I'm running Windows XP Pro and while using IS v5 had no problems. Now I've spent the $200. for the upgrade and it seems that IS doesn't have the necessary files available when the application tells you that you need to down load a specific. I'm seriously thinking about asking for a refund. :mad:

MichaelU
11-28-2005, 11:48 AM
Hi Jim,
You want to download the "SP1 for pre-Windows 2003 Machines" redist.

Christopher Painter
09-21-2006, 02:35 PM
This seems to be every bit as difficult in IS12 Pro. First the release wizard shouldn't allow you to click next unless you have selected at least one language pack. Also the error message saying that it can't find the dotnetfxsp1.exe doesn't indicate any meaningful help in resolving the problem.

Thankfully this thread answered all.