PDA

View Full Version : dotnetfxSp1.exe not found



c40095
10-26-2005, 12:05 PM
Tried creating a project which uses .Net 1.1 . The build complained that 1033dotnetfxSp1.exe was not found .I made a copy of this file to dotnetfxSp1.exe in directory C:\Program Files\InstallShield 11\Redist\0409\i386.


When I tried running setup it installs .Net 1.1 and fails to load service pack 1 for .net.

COuld some one help me out

jberkowitz
10-26-2005, 12:37 PM
I'm a programmer, so I'll answer your question with a question ;-). How are you checking whether the FW SP1 is actually installed? This? -

http://support.microsoft.com/?kbid=318785&sd=msdn


"With the .NET Framework 1.1, a new registry hive has been created specifically to make it easier to find the service pack level. Start Registry Editor, and then locate the following registry key:
Key Name: HKEY_LOCAL_MACHINE\Software\Microsoft\NET Framework Setup\NDP\v1.1.4322
Value: SP
Data type: REG_DWORD
The data in the SP value tells you which service pack is installed for the .NET Framework 1.1. For example, if the value of SP is 0, no service pack is installed for the .NET Framework 1.1. If the value is 1, Service Pack 1 for the .NET Framework 1.1 is installed.

Note that this method cannot be used to detect if any hotfixes are installed for the .NET Framework 1.1."

MichaelU
10-26-2005, 01:03 PM
Another note, as I mention on http://community.installshield.com/showpost.php?p=326159&postcount=5, dotnetfxsp1.exe and 1033dotnetfxsp1.exe are supposed to be two different redistributables. By doing what you've done, the install is now invalid for Windows Server 2003.