PDA

View Full Version : Error applying transforms



SteKra
10-25-2005, 04:20 AM
I've created an installation package with Installshield 11. When I run the package on Windows2003 I got the error message from Windows installer: "Error applying transforms. Verfify that the specified transform paths are valid."
What's the reason for this?
The package always contains 2 mst-files 1031.mst and 1033.mst. Where I have to set this property? In the online-help of Installshield 11 we found, that there exists a MSI property TRANSFORMS, where the mst-files are listed, with or without path. May be the property settings for this are wrong. How can we access this property in Installshield 11?
We had no problems with this project with Installshield 10.5 and 11 before we made the following change:
The change in the installation is, that I had to include .NETFramework 2.0, which requires at least MSI installer3.0.
The version of the msi.dll on the target machine is 3.1.4000.2435.

Any ideas are welcome.
Rgds
Steffen

mspa__
01-17-2006, 04:29 AM
I've got the same problem at the moment with my installation build on InstallShield 11. Too bad there isn't any response on this matter. Is it a too complicated problem or is there still a solution?

On this forum I saw multiple users who have this error, but no one has gotten a reply to it. When i search the web I only get solutions using the Office cleanup utility, which doesnt work for me.

I've tried my installation on a fully clean Windows 2003 Server system, but it still fails there.

What is the solution or how can I get additional logging information during the installation?

Many thanks,

Martijn

mspa__
01-17-2006, 07:44 AM
Some additional info on my problem:

My project was an InstallShield 9.0 project, which compiled works fine. After I convert it to an InstallShield 11 project and compile, it gives the "Error applying transforms" error on Windows 2003 Server. On Windows 2000 and XP the installation works fine.