View Full Version : Windows user changes -> Error 1706

10-11-2005, 07:40 AM
Our application uses InstallShield Express 11 installation.

Our application works just fine in all Windows computers if all users have administrator privileges to his/her computer. However, if the Windows user changes and the new user do not have administrator privileges then Windows configuration procedure cannot finish properly and gives Error 1706. See enclosed GIF-screen shot.

If the user press several times Cancel and OK then our application starts and works completely OK. This extremely annoying feature occurs each time the user starts our application if he/she do not have Administrator privileges.

Why InstallShield installation needs Administrator privileges when Windows configures Our Application to the new user? :confused:

10-11-2005, 09:42 AM
On one of the dialogs, there is a choice to choose if this is installed to all users or just me. If the person installing chooses just me you get this sort of behaviour.

Take out the choice, and make the installer to install it to all users.


10-11-2005, 10:47 AM

Many thanks for the suggestion. However, the default selection is for "All Users" (Show All Users Option) and we have used this.

I have tried to find some switch (option) from IS Express 11 which might affect on this problem, but I have not found any. :(


10-18-2005, 05:13 PM
Can someone please help me out with the same issue.

This error 1706 occurs for me only when I am performing a major upgrade where the previous version is uninstalled and then the new version is installed.

Both versions work fine when installed seperately on theiw own. The issue arises only when doing the upgrade.

The exact same error as described earlier in this thread occurs.

Please assist.