PDA

View Full Version : START | PROGRAMS problem - An easy one?



MikeDonovan
09-27-2005, 10:46 AM
I'm having an issue with launching external files after installing a DemoShield demo on someones computer. It launches some .htm files. Here's the whole story:

The DemoShield demo works just fine when launched after the install if the "Launch Program" is checked. However, when the user goes to START | PROGRAMS | My Company Name | Product and launches it, the Demo starts up, but the .htm files do not come out.

If I right click on the short cut and see the properties, I see that it's launching "C:\Program Files\My Company Name\demo.exe. I browse to that on my computer and launch it and it works fine. The .htm files launch from the DemoShild app.

So, it looks like the problem is coming right from the START | PROGRAMS | part of it. It works with other versions of InstallSheild ( but I upgraded because the "Launch Program" check box was the problem with this same senario, now it's reversed. )

Anyone have ANY idea what might be going on? I've tried several different things and I can't seem to see what the issue might be.

BenSmyth
09-27-2005, 11:31 AM
In the Installation Designer, go to section 3 & then Shortcuts/folders & be sure everything is correct including the Shortcuts tree.

MikeDonovan
09-27-2005, 11:38 AM
I checked it out and everything seems in order. The Demo itself will launch when a user goes to START | PROGRAMS, it's just associated files that won't launch, even though they do if I launch it in other ways (after install, broswe to it). Is there anything in here that would change that?

I checked the setting and it looks like they (the INSTALDIR, the Launch Program, etc...) are all referring to the same file demo.exe file that is installed. Everything will launch the file, but START | PROGRAMS is the only one that seems to see the related files not launch.

MikeDonovan
09-27-2005, 03:40 PM
Ok, I have figured it out. For anyone that experiences the same problem, here's what it was:

The problem WAS the short cut it was creating. I created a short cut manually and it worked that way so I checked the properties of the short cut created by Installshield and the one I created. What was missing in the InstallShield shortcut was the "Start In" property. In Installsheild I changed the "Short Cuts/Folders" Working directory property to my InstallDir and it works fine.

Thank you above for your help. It put me on the right track. :)