PDA

View Full Version : Desktop Icons Not Uninstalled Win98



gharris
09-21-2005, 07:34 PM
I am using Installshield 11 Express, and my install creates two icons, one for desktop and one in the start menu. The target platform OS is Win 98 SE.

When the application is uninstalled the start menu Icon is removed, but the desktop icon remains behind! I can find no settings of any sort that tie this to the uninstall process!

Anyone else run into this and have a workaround?

Thanks,

Gary

GentleGiant
09-22-2005, 12:50 AM
Here are some possibilities that I could think of:
1) Component associated with the shortcut remaining might not be getting uninstalled.
2) It might be a Win98 issue. Try the same on a higher version. If it works fine on the hiher version, try & use the reboot action provided by installshield to make it work on 98.
Do let know if anything helps.

gharris
09-22-2005, 01:05 PM
The desktop icon uninstalles correctly in WIN 2000 and WIN XP, is apparently a WIN 98-related issue.

Now, if I manually reboot the system after uninstall the icon still remains. Are you suggesting I use the "schedule reboot at end" after uninstall completes? Issue here is that I dont want to subject my non-win98 users to this!

Another interesting item is that on WIN 2000, the uninstall icon does not show in the "add remove programs" aplett, just a default folder icon appears. Win XP shows the correct icon here!

I just migrated from the ancient v213 installer which handled all these basic things correctly over all the OS versions! Altho, I'm not planning on going back!

Thanks,

Gary

TsungH
09-22-2005, 03:58 PM
Another interesting item is that on WIN 2000, the uninstall icon does not show in the "add remove programs" aplett, just a default folder icon appears. Win XP shows the correct icon here!
It may be related to a bug in Microsoft Windows Installer. For additional information, please refer to MS KB article 258558 (http://support.microsoft.com/default.aspx?scid=kb;en-us;258558).

gharris
09-22-2005, 09:54 PM
Thanks, Tsung. - The add/remove icon appears to be the installer bug mentioned in the KB article.

I was under the inpression that ISX was using version 2 of the MSI while the article refers to versions 1.0 and 1.1 - perhaps it was never fixed (or my assumption is wrong!)

Regards,

Gary

TsungH
09-27-2005, 10:14 PM
I am led to believe the same problem exists in MSI 2.0 as well.