PDA

View Full Version : Standalone Build issues



tomcat2001
08-24-2005, 02:39 PM
We are supposed to use the Standalone build to produce automated builds. However, upon installing it you find that there's quite a few files missing. These are files you would think would be there. And I have made quite a bit of progress on getting them moved over. However, I'm now getting an error that says:

The Windows Installer 3.1 Engine could not be found. Please download this using the Redistributable Downloader under the Tools menu. It doesn't tell me where it's expecting it or anything. So could someone tell me where to put this.

Aflaat
08-25-2005, 08:54 AM
I filed a support request with IS, they said it is a confirmed bug, and they will fix it in the future.

I also asked the same question on these boards. One person said they moved the file around a bunch and got it to work, but they never told me where to put the file. I've tried guessing all over the place, and haven't guessed right yet. I wish there was a file to look at to tell us where to put it.

For now, I just renamed the 3.1 exe to the name of the 3.0 exe, and tell the isntallers to use the 3.0 exe, even though it is really using the 3.1 exe. Its hacky, but it works for now.

tomcat2001
08-25-2005, 10:56 AM
So I called the support department to get some info on this and they tell me that there's no workaround for this. This is a known bug and they don't even have any way to solve it for people. This is just rediculous. They want to lock everything down for licensing reasons and can't even supply us a way to correctly build our installer.

tomcat2001
08-25-2005, 11:10 AM
For anybody wanting more info, please look at this thread.

http://community.installshield.com/showthread.php?t=149376

It appears there is somewhat of a workaround. I'm in the process of trying it, but supposedly it worked for a couple of people.