View Full Version : Four Errors when converting Express 2.13 Project

Bob Frakes
08-17-2005, 08:04 AM
I'm getting 4 errors when I convert an existing project from Express Version 2.13.

First Error: 1907

This is a Windows Installer Error having to do with Fonts.

Cannot Register Fonts

I have two barcode fonts that I install with my app. These need to be done.

I've tried adding a font description to the project but it didn't help. If I install the application at the Administrator this error does not happen. My local computer has my username with Admin rights. If I install as my local username, I get the error.

Second and Third Error: 1406

This is also a Windows Installer error.

Could not write value versionMajor to the registry on both instances.

No clue as to why...

Fourth Error: 1722

Again a Windows Installer error. This, I think is due to the first three.

The application installs and runs properly, but the above error tells me that it didn't install correctly.

Any clues?


Bob Frakes

Mike Marino
08-17-2005, 10:23 PM
What type of font is this that you are trying to register (TrueType, etc.)?

Bob Frakes
08-18-2005, 05:45 AM
They barcode C39 2 to 1 Narrow and C39 3 to 1 Narrow TrueType fonts.

Mike Marino
08-18-2005, 01:38 PM
Can you send them to me (mmarino@macrovision.com) I will try to see what is going on with them.

Bob Frakes
08-18-2005, 02:49 PM
They've been emailed...


Mike Marino
08-18-2005, 03:32 PM
I created a setup with these fonts, and installed it on a machine (where I am user with admin rights) and I received no error.

The exact windows installer error message is:

Could not register font [2]. Verify that you have sufficient permissions to install fonts, and that the system supports this font.

Where [2] is the font name. My guess is that the account you are using does not have permissions to either the Fonts folder, or the Registry Key where fonts get registered.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

Bob Frakes
08-19-2005, 05:58 AM
Ok, I looked at the user rights for the \Windows subdirectory and I changed them to full rights.

Installed the build and the last error: 1722 is the only one remaining.

Any clues on this one?

Mike Marino
08-19-2005, 01:54 PM
1722 is usually caused by a custom action in the setup that returned a failure code.

Bob Frakes
08-24-2005, 12:32 PM
My old project did not register the application in the Add/Remove Applet. I really don't want the end user to be able to remove the program. This fixed the errors.

Now I'm trying to put an shortcut on the desktop to start the app and everything works except the program icon does not get associated with the shortcut.

In the icon field I'm using: [INSTALLDIR]<ICONFILENAME.ICO>

Any ideas...

08-24-2005, 04:44 PM
In the icon field I'm using: [INSTALLDIR]<ICONFILENAME.ICO>It should reference to a location on your development machine, not on end-user's machine such as [INSTALLDIR].

Bob Frakes
08-25-2005, 10:12 AM
Did what you suggested.

Still not icon associated with the shortcut.

See attached zip file. (PDF enclosed showing error when in shortcut properties page and try to change icon.)


Bob Frakes

08-29-2005, 02:26 PM
You will want to make sure there is no build warning or error about shortcut icon. If there is none, you may want to consider contacting Macrovision eService (http://support.installshield.com/eservice/) for assistance.