PDA

View Full Version : Trouble with feature names



MihaIvan
08-11-2005, 06:00 PM
Well, I just upgraded from version 7. And so I am having some problems with setting up a new project, especially in the area of features.

At first I tried the wizard, but it didn't do what I expected. So I tried the tutorial for MSI projects, and the program doesn't give the results that the tutorial says, and it is in exactly that area where I was confused when doing it on my own.

Reality and the tutorial start to diverge when you get to the Installation Architecture step. The tutorial says the first node in the tree should be Tutorial_Files, but in my tree, it is NewFeature1.

Next, at the Installation Localization step, it tells me how I can change what is displayed to the user for Tutorial_Files, but the only thing in the list of things I can change is the other feature that was added: Help_Files.

Finally, if I go to the Installation Designer, and click on Fetures within the Organization node, and I see a tree with NewFeature1 with a display name of NewFeature1, which is supposed to be Tutorial_Files, and another entry for NewFeature with a display name of Help_Files.

It would seem to me that the names in the tree at least for NewFeature should be Help_Files. How in the world do you check to see if your organization is correct if all you get are names in the tree that are meaningless?

Am I missing something?

RobertDickau
08-12-2005, 08:19 AM
In the Organization/Features view, you modify the internal names in the tree view, and then change what the user will see in the Display Name setting for each feature.

MihaIvan
08-12-2005, 09:47 AM
So when I am making changes in the wizard, that is the name that the user sees, then I have to do it all over again in the tree? Makes more sense to let me do it in project assistant to begin with, then change the user interface name in the installation designer. Or let me declare both in the project assistant rather than turn it into a two step process that is confusing to a beginner.

Thanks.