PDA

View Full Version : Launching another .MSI within my setup is KILLING me...



cada0310
08-10-2005, 12:57 PM
Ok, I've tried everything and the kitchen sink, and I just can't get this to work.

I've tried the LaunchAppAndWait(), which complains that "another setup is running and needs to be completed".

I've tried the custom action running another MSI file, which seems to do nothing at all - the 2nd MSI never gets run.

Been flailing with this all day...anyone have any pointers? Or is there a known issue with trying to do this?


Thanks.

m.rudolph
08-10-2005, 03:51 PM
Are you calling the .MSI directly or using a setup.exe/setup.bat to call the .MSI?

cada0310
08-11-2005, 08:04 AM
Hi,

Thanks for your reply. I'm calling the MSI directly; one technique I tried was using the "Launch another MSI" custom action. The main trouble I ran into with this technique was that InstallShield could never seem to "find" my MSI file to run. I'd specify [SOURCEDIR]foo.msi, [TARGETDIR]foo.msi, and whatever I tried I'd get a dialog that it couldn't be located.

m.rudolph
08-11-2005, 09:44 AM
You should have a setup.exe launching the MSI.

I ran into the same problem thinking the setup.exe was redundant. I've even had problems calling setup.exe and in most cases I call a setup.bat with parameters and use the LAAW_OPTION_HIDDEN.

It seems to work 100% of the time with the batch file. I don't know if it's a bug or my own ignorance honestly, but whatever works ; )

cada0310
08-11-2005, 10:23 AM
Ah, I see - I don't have the option of having a setup.exe launching the MSI, as it's someone else's MSI file, but I could do the batch file thing.

Do you think that would work? Having a SETUP.BAT file just run the MSIEXEC or something like that, and calling it with LaunchAppAndWait?

m.rudolph
08-11-2005, 01:38 PM
Should work with msiexec.

This can go in the batch file:

msiexec /i MyMSIFile.msi

Where MyMSIFile.msi is your MSI file.

Then call LaunchAppAndWait ( TARGETDIR ^ "\\Folder\\setup.bat", "", WAIT | LAAW_OPTION_HIDDEN ); or something similar.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/msiexec.mspx

That site has all the switches. Good luck.

cada0310
08-12-2005, 09:47 AM
Thought we had it for a second there...the batch file launches, the MSI comes up, but after I put in the target directory, I get a "There is another installation already in progress." and can't continue.