PDA

View Full Version : Warning -5000



MarcusM
08-08-2005, 04:28 AM
I get the following warnings during building of my projects:

====================================================
Feature: Script
Komponente: <Support>Script
ISDEV : warning -5000: Component '<Support>Script' contains a link to a nonexistent file - 'E:\Installationen\xxx\xxx\Script Files\setup.inx'
====================================================

and

====================================================
Feature: Disk<1>
Komponente: <Disk1>Disk1 Files(1)
Komponente: <Disk1>Disk1 Files(2)
Komponente: <Disk1>Disk1 Files(3)
ISDEV : warning -5000: Component '<Disk1>Disk1 Files(3)' contains a link to a nonexistent file - 'E:\Installationen\ASC\InterActionServer\Script Files\setup.inx'
====================================================

This happens after a transition of the project from DevStudio 9 to InstallShield 11 Professional and reordering some self-set pathvariables. I've found a similar thread in InstallShield 10.5 section, but there haven't been any answers to it although the question was put some time ago now.

The actual script files directory lies under the <ISProjectDataFolder>, not the <ISProjectFolder>, as the compiler seems to asume. For all other script-based operations, InstallShield uses the correct path <ISProjectDataFolder>\Script files\. I get no errors or warnings compiling only the scripts. This happens only after building. I haven't found out how I can change this path to the correct one. All pathvariables are set and recognized correctly, at least they're shown as being recognized correctly.

Any ideas on how I might solve this problem?

Thanks in advance,

Marcus

puneet404
08-08-2005, 04:39 AM
Please refer to the following KB article:

http://support.installshield.com/kb/view.asp?articleid=Q107027

Hope it helps. :D

MarcusM
08-08-2005, 05:00 AM
Thanks for the quick reply, but no, doesn't help me. I use the ODBC merge module, not the Windows CE module. I also have found this article and I did the described steps nevertheless, but that hasn't helped me.

Any other ideas?

m.rudolph
08-08-2005, 12:40 PM
If it's on a build, try using the release wizard instead to build the media. See what happens (probably wont fix it, but worth a shot).

MarcusM
08-09-2005, 02:33 AM
I created a new release using the wizard but the problem stays the same. As a workaround I now compile the scripts and copy the script folder manually to the location where IS looks for the specified files. Not nice but it works for now.

I have to to say that the transition from IS 9 to 11 is not that easy. I'm trying to get the string tables to work again at the moment.

DIGGIDY
07-25-2008, 05:54 AM
I had this exact same problem, it seems for some strange reason that when in inserted these scripts into the project from a source other than the default 'Setup Files' directory it started compiling them into the directory the scripts were inserted from... :confused:

However this can be fixed by hacking the ism file...

1) Open the project's ism file in notepad

2) Search for this line in the ism file...

<table name="InstallShield">

3) Then scroll down untill you find this line...

<row><td>ISCompilerOption_OutputPath</td><td>...

4) Somehow the output path for the compiled scripts had been change, I just reset this to the 'Setup Files' path and it all worked fine after that, no errors or warning...

like so...

<row><td>ISCompilerOption_OutputPath</td><td>&lt;ISProjectDataFolder&gt;\Script Files</td></row>


hope that helps
DIG's ;)

MarcusM
07-25-2008, 06:09 AM
Thanks. After almost three years now I've forgotten about this problem.

I don't know if I had solved it but probably not or else I would have mentioned it here. Another problem, to which, if I remeber correctly, I also posted a thread, proved much worse than this (the string tables wouldn't be read during runtime) and this problem couldn't be solved. In fact I created some new setup projects because of the string table error and rebuild the old projects that way. Wasn't nice.

But thanks all the same :)