PDA

View Full Version : Can't add Function in Custom Action...



ebaichtal
08-05-2005, 03:28 PM
I have a Basic MSI Project, realized I needed to write some Installscript code and the setup.rul was created and I modified it.

Now I am trying to add the functions through the Custom Actions. I've tried the Custom Action Wizard and just adding a New Installscript Object, and I get NOTHING in the drop-down menus for Function Name. (Can't even type one in!)

-Ed

puneet404
08-08-2005, 04:30 AM
Its just a suggestion:

After creating the function in setup.rul, if you didn't find the function name in the dropdown list while creating a CA then I will suggest you to save the project and close the IDE of IS and the re-open the project.

I hope this helps you :rolleyes:

nolindom
08-09-2005, 11:06 AM
Hi,

I found this in the InstallShield help and it solved my problem:

The prototype of any function that is called directly by the setup engine must be marked as export. An example is shown below:

export prototype NewFeature1_Installing();


Hope this helps.